wfiltericf wfilter_internet_content_filter 在web页面生成时对输入的转义处理不恰当(跨站脚本)

CVE编号

CVE-2021-3243

利用情况

暂无

补丁情况

N/A

披露时间

2021-04-16
漏洞描述
Wfilter ICF 5.0.117 contains a cross-site scripting (XSS) vulnerability. An attacker in the same LAN can craft a packet with a malicious User-Agent header to inject a payload in its logs, where an attacker can take over the system by through its plugin-running function.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 wfiltericf wfilter_internet_content_filter 5.0.117 -
运行在以下环境
系统 debian_10 gpac * Up to
(excluding)
0.5.2-426-gc5ad4e4+dfsg5-5
运行在以下环境
系统 debian_11 gpac * Up to
(excluding)
1.0.1+dfsg1-4+deb11u1
运行在以下环境
系统 debian_12 gpac * Up to
(excluding)
1.0.1+dfsg1-5
运行在以下环境
系统 debian_9 gpac * Up to
(excluding)
0.5.2-426-gc5ad4e4+dfsg5-3+deb9u1
运行在以下环境
系统 debian_sid gpac * Up to
(excluding)
1.0.1+dfsg1-5
运行在以下环境
系统 fedora_34 abcm2ps-debuginfo * Up to
(excluding)
8.14.13-1.fc34
运行在以下环境
系统 fedora_35 abcm2ps-debuginfo * Up to
(excluding)
8.14.13-1.fc35
运行在以下环境
系统 fedora_36 abcm2ps-debuginfo * Up to
(excluding)
8.14.13-1.fc36
运行在以下环境
系统 fedora_EPEL_7 abcm2ps-debuginfo * Up to
(excluding)
8.14.13-1.el7
运行在以下环境
系统 fedora_EPEL_8 abcm2ps-debuginfo * Up to
(excluding)
8.14.13-1.el8
运行在以下环境
系统 opensuse_Leap_15.3 abcm2ps * Up to
(excluding)
8.14.13-bp153.2.3.1
CVSS3评分
6.1
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况