中危 abcm2ps 缓冲区错误漏洞(CVE-2021-32435)

CVE编号

CVE-2021-32435

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-03-11
漏洞描述

abcm2ps是美国Sammy S.个人开发者的一个命令行程序。可将音乐曲调从 ABC 音乐符号转换为 PostScript 或 SVG。

abcm2ps v8.14.11存在安全漏洞,该漏洞允许远程攻击者通过未指定的向量导致拒绝服务 (DoS)。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/leesavide/abcm2ps/issues/84
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 abcm2ps_project abcm2ps 8.14.11 -
运行在以下环境
系统 debian_10 abcm2ps * Up to
(including)
8.14.2-0.2
运行在以下环境
系统 debian_11 abcm2ps * Up to
(including)
8.14.11-0.1
运行在以下环境
系统 debian_12 abcm2ps * Up to
(including)
8.14.11-0.1
运行在以下环境
系统 debian_9 abcm2ps * Up to
(excluding)
7.8.9-1+deb9u1
运行在以下环境
系统 fedora_34 abcm2ps * Up to
(excluding)
8.14.13-1.fc34
运行在以下环境
系统 fedora_35 abcm2ps * Up to
(excluding)
8.14.13-1.fc35
运行在以下环境
系统 fedora_36 abcm2ps * Up to
(excluding)
8.14.13-1.fc36
运行在以下环境
系统 fedora_EPEL_7 abcm2ps * Up to
(excluding)
8.14.13-1.el7
运行在以下环境
系统 fedora_EPEL_8 abcm2ps * Up to
(excluding)
8.14.13-1.el8
运行在以下环境
系统 opensuse_Leap_15.3 abcm2ps * Up to
(excluding)
8.14.13-bp153.2.3.1
阿里云评分
5.7
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况