中危 Jupyter Notebook跨站脚本漏洞

CVE编号

CVE-2021-32798

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-08-10
漏洞描述
Jupyter Notebook是一套用于创建、共享代码和说明性文本文档的开源的web应用程序
Jupyter Notebook存在安全漏洞,该漏洞源于它使用不推荐的Google Caja版本来清理用户输入。当受害者在Jupyter Notebook中打开恶意ipynd文档时,可以触发XSS。攻击者利用该漏洞在受害者电脑上执行任意代码
解决建议
目前官方已经发布升级补丁已修复漏洞,补丁获取连接:

https://github.com/jupyter/notebook/security/advisories/GHSA-hwvp-6gjx-j797
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 jupyter notebook * From
(including)
5.7.0
Up to
(excluding)
5.7.11
运行在以下环境
应用 jupyter notebook 6.4.0 -
运行在以下环境
系统 debian_10 jupyter-notebook * Up to
(including)
5.7.8-1
运行在以下环境
系统 debian_11 jupyter-notebook * Up to
(including)
6.2.0-1
运行在以下环境
系统 debian_12 jupyter-notebook * Up to
(including)
6.2.0-1
运行在以下环境
系统 debian_9 jupyter-notebook * Up to
(including)
4.2.3-4
运行在以下环境
系统 debian_sid jupyter-notebook * Up to
(including)
6.2.0-1
阿里云评分
5.7
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况