中危 linux linux_kernel 释放后使用

CVE编号

CVE-2021-33033

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-05-15
漏洞描述
The Linux kernel before 5.11.14 has a use-after-free in cipso_v4_genopt in net/ipv4/cipso_ipv4.c because the CIPSO and CALIPSO refcounting for the DOI definitions is mishandled, aka CID-ad5d07f4a9cd. This leads to writing an arbitrary value.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 amazon_AMI kernel * Up to
(excluding)
4.14.232-123.381.amzn1
运行在以下环境
系统 centos_7 kernel * Up to
(excluding)
3.10.0-1160.36.2.el7
运行在以下环境
系统 centos_8 linux * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 debian_10 linux * Up to
(excluding)
4.19.181-1
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.303-1
运行在以下环境
系统 linux linux_kernel * Up to
(excluding)
5.11.14
运行在以下环境
系统 opensuse_Leap_15.2 linux * Up to
(excluding)
5.3.18-lp152.98.1.lp152.8.46.1
运行在以下环境
系统 opensuse_Leap_15.3 linux * Up to
(excluding)
5.3.18-38.28.2
运行在以下环境
系统 oracle_7 kernel * Up to
(excluding)
3.10.0-1160.36.2.el7
运行在以下环境
系统 redhat_7 kernel-rt * Up to
(excluding)
0:3.10.0-1160.36.2.rt56.1179.el7
运行在以下环境
系统 redhat_8 kernel * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 suse_12_SP5 linux * Up to
(excluding)
4.12.14-122.98.1
运行在以下环境
系统 ubuntu_14.04 linux * Up to
(excluding)
4.15.0-1115.128~14.04.1
运行在以下环境
系统 ubuntu_14.04.6_lts linux-azure * Up to
(excluding)
4.15.0-1115.128~14.04.1
运行在以下环境
系统 ubuntu_16.04 linux * Up to
(excluding)
4.15.0-1115.128~16.04.1
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
4.15.0-1092.94
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.15.0-144.148
运行在以下环境
系统 ubuntu_20.04 linux * Up to
(excluding)
5.4.0-1043.45
运行在以下环境
系统 ubuntu_21.10 linux * Up to
(excluding)
5.11.0-1005.5
阿里云评分
5.4
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    N/A
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况