低危 Apache Tomcat 环境问题漏洞

CVE编号

CVE-2021-33037

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-07-12
漏洞描述
Apache Tomcat是美国阿帕奇(Apache)基金会的一款轻量级Web应用服务器。该程序实现了对Servlet和JavaServer Page(JSP)的支持。
Apache Tomcat存在环境问题漏洞,该漏洞源于Apache Tomcat 在某些情况下没有正确解析 HTTP 传输编码请求标头,导致在与反向代理一起使用时可能会请求走私。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://lists.apache.org/thread.html/r612a79269b0d5e5780c62dfd34286a8037232fec0bc6f1a7e60c9381%40%3Cannounce.tomcat.apache.org%3E
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache tomcat * From
(excluding)
10.0.0
Up to
(including)
10.0.6
运行在以下环境
应用 apache tomcat * From
(excluding)
9.0.0
Up to
(including)
9.0.46
运行在以下环境
应用 apache tomcat * From
(including)
8.5.0
Up to
(including)
8.5.66
运行在以下环境
系统 amazon_AMI tomcat8 * Up to
(excluding)
8.5.69-1.88.amzn1
运行在以下环境
系统 debian_10 tomcat8 * Up to
(excluding)
9.0.31-1~deb10u5
运行在以下环境
系统 debian_11 tomcat8 * Up to
(excluding)
9.0.43-2~deb11u1
运行在以下环境
系统 debian_9 tomcat8 * Up to
(excluding)
8.5.54-0+deb9u7
运行在以下环境
系统 debian_sid tomcat8 * Up to
(including)
9.0.43-1
运行在以下环境
系统 opensuse_Leap_15.2 tomcat8 * Up to
(excluding)
9.0.36-lp152.2.25.1
运行在以下环境
系统 opensuse_Leap_15.3 tomcat8 * Up to
(excluding)
9.0.36-13.1
运行在以下环境
系统 suse_12_SP5 tomcat8 * Up to
(excluding)
9.0.36-3.71.1
运行在以下环境
系统 ubuntu_18.04 tomcat9 * Up to
(excluding)
9.0.16-3ubuntu0.18.04.2
运行在以下环境
系统 ubuntu_20.04 tomcat9 * Up to
(excluding)
9.0.31-1ubuntu0.2
阿里云评分
3.4
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-444 HTTP请求的解释不一致性(HTTP请求私运)
阿里云安全产品覆盖情况