中危 Apache HTTP Server HTTP请求走私漏洞

CVE编号

CVE-2021-33193

利用情况

暂无

补丁情况

没有补丁

披露时间

2021-10-25 00:00:00
漏洞描述
Apache HTTP Server是美国阿帕奇(Apache)基金会的一款开源网页服务器。该服务器具有
快速、可靠且可通过简单的API进行扩充的特点。
Apache HTTP Server 2.4.17-2.4.48之间版本存在HTTP请求走私漏洞。该漏洞源于程序未对 mod_proxy中的HTTP/2请求进行正确验证。远程攻击者可利用该漏洞通过向服务器发送特制HTTP/2请求导致Web服务器缓存中毒并执行网络钓鱼攻击。
受影响系统:
Apache HTTP Server >= 2.4.17
Apache HTTP Server <= 2.4.48
解决建议
目前厂商暂未发布修复措施解决此安全问题。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * From
(including)
2.4.17
Up to
(including)
2.4.48
运行在以下环境
系统 alpine_3.11 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.12 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.13 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.14 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.15 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_edge httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.51-1.amzn2
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.51-1.94.amzn1
运行在以下环境
系统 debian_10 httpd * Up to
(excluding)
2.4.38-3+deb10u5
运行在以下环境
系统 debian_11 httpd * Up to
(excluding)
2.4.48-3.1+deb11u1
运行在以下环境
系统 debian_9 httpd * Up to
(excluding)
2.4.25-3+deb9u9
运行在以下环境
系统 fedora_33 httpd * Up to
(excluding)
2.4.50-1.fc33
运行在以下环境
系统 fedora_34 httpd * Up to
(excluding)
2.4.50-1.fc34
运行在以下环境
系统 fedora_35 httpd * Up to
(excluding)
2.4.50-1.fc35
运行在以下环境
系统 opensuse_Leap_15.2 httpd * Up to
(excluding)
2.4.43-lp152.2.18.1
运行在以下环境
系统 opensuse_Leap_15.3 httpd * Up to
(excluding)
2.4.43-3.25.1
运行在以下环境
系统 suse_12_SP5 httpd * Up to
(excluding)
2.4.23-29.77.2
阿里云评分
6.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况