高危 Linux kernel缓冲区溢出漏洞(CNVD-2021-39045)

CVE编号

CVE-2021-33200

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-05-27
漏洞描述
Linux kernel是美国Linux基金会的开源操作系统Linux所使用的内核。

Linux Kernel 5.12.7版本及之前版本中存在缓冲区错误漏洞,该漏洞源于对指针算术操作强制执行不正确的限制,可能会滥用这些操作在内核内存中执行越位的读写操作。攻击者可通过该漏洞从本地特权升级到root。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://www.openwall.com/lists/oss-security/2021/05/27/1
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 amazon_2 kernel * Up to
(excluding)
4.14.232-177.418.amzn2
运行在以下环境
系统 amazon_AMI kernel * Up to
(excluding)
4.14.238-125.421.amzn1
运行在以下环境
系统 centos_8 kernel * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 fedoraproject fedora 33 -
运行在以下环境
系统 fedora_33 kernel * Up to
(excluding)
5.12.8-200.fc33
运行在以下环境
系统 fedora_34 kernel * Up to
(excluding)
5.12.8-300.fc34
运行在以下环境
系统 linux linux_kernel * Up to
(including)
5.12.7
运行在以下环境
系统 opensuse_Leap_15.2 kernel * Up to
(excluding)
5.3.18-lp152.78.1
运行在以下环境
系统 opensuse_Leap_15.3 kernel * Up to
(excluding)
4.12.14-197.99.1
运行在以下环境
系统 oracle_8 kernel * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 redhat_8 kernel * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 suse_12_SP5 kernel * Up to
(excluding)
4.12.14-16.59.1
运行在以下环境
系统 ubuntu_14.04.6_lts linux * Up to
(excluding)
3.11.0-12.19
运行在以下环境
系统 ubuntu_16.04 kernel * Up to
(excluding)
4.15.0-1109.116~16.04.1
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
4.13.0-16.19
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.13.0-16.19
运行在以下环境
系统 ubuntu_21.04 linux * Up to
(excluding)
5.11.0-22.23
阿里云评分
7.0
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况