中危 linux linux_kernel 对生成代码的控制不恰当(代码注入)

CVE编号

CVE-2021-3411

利用情况

暂无

补丁情况

没有补丁

披露时间

2021-03-10
漏洞描述
Linux kernel是一种计算机操作系统内核,以C语言和汇编语言写成,符合POSIX标准,按GNU通用公共许可证发行。

Linux kernel 5.10之前版本存在内存访问冲突漏洞。攻击者可利用该漏洞影响数据机密性、完整性以及系统可用性。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://ubuntu.com/security/CVE-2021-3411
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat openshift_container_platform 4.4 -
运行在以下环境
应用 redhat openshift_container_platform 4.5 -
运行在以下环境
应用 redhat openshift_container_platform 4.6 -
运行在以下环境
应用 redhat openshift_container_platform 4.7 -
运行在以下环境
系统 linux linux_kernel * Up to
(excluding)
5.10
运行在以下环境
系统 oracle linux_7 kernel * Up to
(excluding)
5.4.17-2102.201.3.el7
运行在以下环境
系统 oracle_7 linux-riscv-5.8 * Up to
(excluding)
5.4.17-2102.201.3.el8
运行在以下环境
系统 redhat enterprise_linux 7.0 -
运行在以下环境
系统 redhat enterprise_linux 8.0 -
运行在以下环境
系统 ubuntu_16.04.7_lts linux * Up to
(excluding)
4.2.0-16.19
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.2.0-16.19
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.13.0-16.19
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.13.0-16.19
运行在以下环境
系统 ubuntu_20.04 linux-riscv-5.8 * Up to
(excluding)
5.8.0-17.19~20.04.1
运行在以下环境
系统 ubuntu_21.10 linux-hwe-5.8 * Up to
(excluding)
5.11.0-1006.6
阿里云评分
5.7
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    管控权限
  • 影响范围
    全局影响
  • EXP成熟度
    N/A
  • 补丁情况
    没有补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况