低危 .NET Core 和 Visual Studio 信息泄露漏洞

CVE编号

CVE-2021-34485

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-08-10
漏洞描述
Microsoft .NET Core和Microsoft Visual Studio都是美国微软(Microsoft)公司的产品。.NET Core是一套免费的开源开发平台。该平台具有多语言支持和跨平台等特点。Microsoft Visual Studio是一款开发工具套件系列产品,也是一个基本完整的开发工具集,它包括了整个软件生命周期中所需要的大部分工具。

Microsoft .NET Core & Visual Studio存在信息泄露漏洞。以下产品和版本受到影响:Microsoft Visual Studio 2017 version 15.9 (includes 15.0 - 15.8),Microsoft Visual Studio 2019 version 16.4 (includes 16.0 - 16.3),Microsoft Visual Studio 2019 version 16.7 (includes 16.0 – 16.6),Microsoft Visual Studio 2019 version 16.9 (includes 16.0 - 16.8),Microsoft Visual Studio 2019 version 16.10 (includes 16.0 - 16.9),.NET Core 2.1,.NET Core 3.1,.NET 5.0。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2021-34485
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 microsoft .net * From
(including)
5.0
Up to
(including)
5.0.8
运行在以下环境
应用 microsoft .net_core * From
(including)
2.1
Up to
(including)
2.1.28
运行在以下环境
应用 microsoft .net_core * From
(including)
3.1
Up to
(including)
3.1.17
运行在以下环境
应用 microsoft powershell_core * From
(including)
7.0
Up to
(excluding)
7.0.7
运行在以下环境
应用 microsoft powershell_core * From
(including)
7.1
Up to
(excluding)
7.1.4
运行在以下环境
应用 microsoft visual_studio_2017 * From
(including)
15.0
Up to
(including)
15.9
运行在以下环境
应用 microsoft visual_studio_2019 * From
(including)
16.0
Up to
(including)
16.10
运行在以下环境
系统 alibaba_cloud_linux_2.1903 dotnet-runtime-2.1 * Up to
(excluding)
3.1.18-1.1.al8
运行在以下环境
系统 centos_8 dotnet-debugsource * Up to
(excluding)
2.1.525-1.el8_4
运行在以下环境
系统 oracle_8 dotnet-runtime-2.1 * Up to
(excluding)
2.1.525-1.el8_4
运行在以下环境
系统 redhat_8 dotnet-runtime-2.1 * Up to
(excluding)
2.1.29-1.el8_4
运行在以下环境
系统 ubuntu_8 dotnet-debugsource * Up to
(excluding)
2.1.525-1.el8_4
阿里云评分
3.9
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况