低危 openssl openssl 证书验证不恰当

CVE编号

CVE-2021-3450

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-03-26 04:15:00
漏洞描述
OpenSSL是Openssl团队的一个开源的能够实现安全套接层(SSLv2/v3)和安全传输层(TLSv1)协议的通用加密库。该产品支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。
OpenSSL 1.1.1h-1.1.1j 存在信任管理问题漏洞,该漏洞允许绕过ca证书检查。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-openssl-2021-GHY28dJd
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openssl openssl * From
(including)
1.1.1h
Up to
(excluding)
1.1.1k
2
运行在以下环境
系统 alpine_3.14 openssl * Up to
(excluding)
1.1.1k-r0
3
运行在以下环境
系统 alpine_3.9 openssl * Up to
(excluding)
1.1.1k-r0
4
运行在以下环境
系统 alpine_3.11 openssl * Up to
(excluding)
1.1.1k-r0
5
运行在以下环境
系统 alpine_3.12 openssl * Up to
(excluding)
1.1.1k-r0
6
运行在以下环境
系统 alpine_3.13 openssl * Up to
(excluding)
1.1.1k-r0
7
运行在以下环境
系统 alpine_3.10 openssl * Up to
(excluding)
1.1.1k-r0
8
运行在以下环境
系统 amazon_2 openssl * Up to
(excluding)
1.1.1g-12.amzn2.0.3
9
运行在以下环境
系统 alpine_edge openssl * Up to
(excluding)
1.1.1k-r0
10
运行在以下环境
系统 opensuse_Leap_15.3 openssl * Up to
(excluding)
10.24.1-1.36.1
11
运行在以下环境
系统 opensuse_Leap_15.2 openssl * Up to
(excluding)
12.22.2-lp152.3.15.1
12
运行在以下环境
系统 opensuse_Leap_15.3 openssl * Up to
(excluding)
12.22.2-4.16.1
13
运行在以下环境
系统 opensuse_Leap_15.2 openssl * Up to
(excluding)
10.24.1-lp152.2.15.1
14
运行在以下环境
系统 oracle_8 openssl * Up to
(excluding)
1.1.1g-15.el8_3
15
运行在以下环境
系统 fedora_EPEL_7 openssl * Up to
(excluding)
1.1.1g-3.el7
16
运行在以下环境
系统 redhat_8 openssl * Up to
(excluding)
1.1.1g-15.el8_3
17
运行在以下环境
系统 centos_8 openssl * Up to
(excluding)
1.1.1g-15.el8_3
18
运行在以下环境
系统 fedora_34 openssl * Up to
(excluding)
1.1.1k-1.fc34
阿里云评分
2.5
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况