中危 Google Golang 信任管理问题漏洞

CVE编号

CVE-2021-34558

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-07-15
漏洞描述
Google Golang是美国谷歌(Google)公司的一种静态强类型、编译型语言。Go的语法接近C语言,但对于变量的声明有所不同。Go支持垃圾回收功能。Go的并行模型是以东尼·霍尔的通信顺序进程(CSP)为基础,采取类似模型的其他语言包括Occam和Limbo,但它也具有Pi运算的特征,比如通道传输。在1.8版本中开放插件(Plugin)的支持,这意味着现在能从Go中动态加载部分函数。
Golang through 1.16.5 存在信任管理问题漏洞,该漏洞源于在进行基于 RSA 的密钥交换时,crypto/tls 包没有正确断言 X.509 证书中的公钥类型与预期类型匹配。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://groups.google.com/g/golang-announce/c/n9FxMelZGAQ
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 golang go * Up to
(including)
1.16.5
运行在以下环境
系统 alibaba_cloud_linux_2.1903 go * Up to
(excluding)
1.15.14-1.1.al8
运行在以下环境
系统 alpine_3.13 go * Up to
(excluding)
1.15.14-r0
运行在以下环境
系统 alpine_3.14 go * Up to
(excluding)
1.16.6-r0
运行在以下环境
系统 alpine_3.15 go * Up to
(excluding)
1.16.6-r0
运行在以下环境
系统 alpine_3.16 go * Up to
(excluding)
1.16.6-r0
运行在以下环境
系统 alpine_edge go * Up to
(excluding)
1.16.6-r0
运行在以下环境
系统 amazon_2 go * Up to
(excluding)
1.15.14-1.amzn2.0.1
运行在以下环境
系统 amazon_AMI go * Up to
(excluding)
1.15.14-1.69.amzn1
运行在以下环境
系统 centos_8 go * Up to
(excluding)
7.5.9-4.el8
运行在以下环境
系统 debian_10 go * Up to
(including)
1.11.6-1+deb10u4
运行在以下环境
系统 debian_11 go * Up to
(including)
1.15.9-5
运行在以下环境
系统 debian_9 go * Up to
(including)
1.7.4-2+deb9u1
运行在以下环境
系统 debian_sid go * Up to
(including)
1.15.9-5
运行在以下环境
系统 fedora_33 go * Up to
(excluding)
1.21.4-5.fc33
运行在以下环境
系统 fedora_34 go * Up to
(excluding)
7.5.10-1.fc34
运行在以下环境
系统 fedora_EPEL_7 go * Up to
(excluding)
1.15.14-1.el7
运行在以下环境
系统 opensuse_Leap_15.2 go * Up to
(excluding)
1.16.6-lp152.5.1
运行在以下环境
系统 opensuse_Leap_15.3 go * Up to
(excluding)
1.16.6-1.20.1
运行在以下环境
系统 oracle_8 go * Up to
(excluding)
1.15.14-1.module+el8.4.0+20290+7af514f4
运行在以下环境
系统 redhat_8 go * Up to
(excluding)
7.5.9-4.el8
阿里云评分
5.2
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况