中危 avahi avahi 不可达退出条件的循环(无限循环)

CVE编号

CVE-2021-3468

利用情况

暂无

补丁情况

没有补丁

披露时间

2021-06-03 00:15:00
漏洞描述
A flaw was found in avahi in versions 0.6 up to 0.8. The event used to signal the termination of the client connection on the avahi Unix socket is not correctly handled in the client_work function, allowing a local attacker to trigger an infinite loop. The highest threat from this vulnerability is to the availability of the avahi service, which becomes unresponsive after this flaw is triggered.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 avahi avahi * From
(including)
0.6
Up to
(including)
0.8
运行在以下环境
系统 alpine_3.11 avahi * Up to
(excluding)
0.8-r1
运行在以下环境
系统 alpine_3.12 avahi * Up to
(excluding)
0.8-r1
运行在以下环境
系统 alpine_3.13 avahi * Up to
(excluding)
0.8-r3
运行在以下环境
系统 alpine_3.14 avahi * Up to
(excluding)
0.8-r4
运行在以下环境
系统 alpine_3.15 avahi * Up to
(excluding)
0.8-r4
运行在以下环境
系统 alpine_edge avahi * Up to
(excluding)
0.8-r4
运行在以下环境
系统 debian_10 avahi * Up to
(excluding)
0.7-4+deb10u1
运行在以下环境
系统 debian_11 avahi * Up to
(excluding)
0.8-5
运行在以下环境
系统 debian_12 avahi * Up to
(excluding)
0.8-5
运行在以下环境
系统 debian_9 avahi * Up to
(excluding)
0.6.32-2
运行在以下环境
系统 debian_sid avahi * Up to
(excluding)
0.8-5
运行在以下环境
系统 opensuse_Leap_15.2 avahi * Up to
(excluding)
0.7-lp152.3.9.1
运行在以下环境
系统 opensuse_Leap_15.3 avahi * Up to
(excluding)
0.6.32-5.13.1
运行在以下环境
系统 suse_12_SP5 avahi * Up to
(excluding)
0.6.32-32.15.1
运行在以下环境
系统 ubuntu_14.04 avahi * Up to
(excluding)
0.6.31-4ubuntu1.3+esm1
运行在以下环境
系统 ubuntu_14.04.6_lts avahi * Up to
(excluding)
0.6.31-4ubuntu1.3+esm1
运行在以下环境
系统 ubuntu_16.04 avahi * Up to
(excluding)
0.6.32~rc+dfsg-1ubuntu2.3+esm1
运行在以下环境
系统 ubuntu_18.04 avahi * Up to
(excluding)
0.7-3.1ubuntu1.3
运行在以下环境
系统 ubuntu_18.04.5_lts avahi * Up to
(excluding)
0.7-3.1ubuntu1.3
运行在以下环境
系统 ubuntu_20.04 avahi * Up to
(excluding)
0.7-4ubuntu7.1
运行在以下环境
系统 ubuntu_21.04 avahi * Up to
(excluding)
0.8-5ubuntu3
阿里云评分
4.1
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    没有补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-835 不可达退出条件的循环(无限循环)
阿里云安全产品覆盖情况