中危 linux linux_kernel 跨界内存写

CVE编号

CVE-2021-3489

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-06-04
漏洞描述
The eBPF RINGBUF bpf_ringbuf_reserve() function in the Linux kernel did not check that the allocated size was smaller than the ringbuf size, allowing an attacker to perform out-of-bounds writes within the kernel and therefore, arbitrary code execution. This issue was fixed via commit 4b81ccebaeee ("bpf, ringbuf: Deny reserve of buffers larger than ringbuf") (v5.13-rc4) and backported to the stable kernels in v5.12.4, v5.11.21, and v5.10.37. It was introduced via 457f44363a88 ("bpf: Implement BPF ring buffer and verifier support for it") (v5.8-rc1).
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 amazon_2 kernel * Up to
(excluding)
5.10.47-39.130.amzn2
运行在以下环境
系统 canonical ubuntu_linux 20.04 -
运行在以下环境
系统 canonical ubuntu_linux 20.10 -
运行在以下环境
系统 canonical ubuntu_linux 21.04 -
运行在以下环境
系统 centos_8 kernel * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 fedora_32 kernel * Up to
(excluding)
5.11.20-100.fc32
运行在以下环境
系统 fedora_33 kernel * Up to
(excluding)
5.11.20-200.fc33
运行在以下环境
系统 fedora_34 kernel * Up to
(excluding)
5.11.20-300.fc34
运行在以下环境
系统 linux linux_kernel * From
(including)
5.11
Up to
(excluding)
5.11.21
运行在以下环境
系统 linux linux_kernel * From
(including)
5.12
Up to
(excluding)
5.12.4
运行在以下环境
系统 linux linux_kernel * From
(including)
5.8
Up to
(excluding)
5.10.37
运行在以下环境
系统 linux linux_kernel 5.13 -
运行在以下环境
系统 opensuse_Leap_15.3 kernel * Up to
(excluding)
5.3.18-38.3.1
运行在以下环境
系统 opensuse_Leap_15.3 kernel * Up to
(excluding)
5.3.18-59.5.2
运行在以下环境
系统 opensuse_Leap_15.3 kernel * Up to
(excluding)
5.3.18-59.5.2.18.2.2
运行在以下环境
系统 oracle_8 kernel * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 redhat_8 kernel * Up to
(excluding)
4.18.0-348.el8
运行在以下环境
系统 ubuntu_20.04 kernel * Up to
(excluding)
5.8.0-53.60~20.04.1
运行在以下环境
系统 ubuntu_21.04 kernel * Up to
(excluding)
5.11.0-1005.5
运行在以下环境
系统 ubuntu_21.10 kernel * Up to
(excluding)
5.11.0-1007.7+21.10.1
阿里云评分
4.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况