中危 libxml2内存错误引用漏洞(CVE-2021-3516)

CVE编号

CVE-2021-3516

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-06-01
漏洞描述
libxml2是开源的一个用来解析XML文档的函数库。它用C语言写成,并且能为多种语言所调用,例如C语言,C++,XSH。
libxml2 2.9.11之前版本存在内存错误引用漏洞。攻击者可借助特制文件利用该漏洞触发释放后重用。

受影响系统:
libxml2 xmllint < 2.9.11
解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://gitlab.gnome.org/GNOME/libxml2/-/commit/1358d157d0bd83be1dfe356a69213df9fac0b539
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat jboss_core_services - -
运行在以下环境
应用 xmlsoft xmllint * Up to
(excluding)
2.9.11
运行在以下环境
系统 amazon_2 libxml2 * Up to
(excluding)
2.9.1-6.amzn2.5.4
运行在以下环境
系统 centos_8 libxml2 * Up to
(excluding)
2.9.7-9.el8_4.2
运行在以下环境
系统 debian_10 libxml2 * Up to
(excluding)
2.9.4+dfsg1-7+deb10u2
运行在以下环境
系统 debian_11 libxml2 * Up to
(including)
2.9.10+dfsg-6.3
运行在以下环境
系统 debian_9 libxml2 * Up to
(excluding)
2.9.4+dfsg1-2.2+deb9u4
运行在以下环境
系统 debian_sid libxml2 * Up to
(including)
2.9.10+dfsg-6.3
运行在以下环境
系统 fedora_33 libxml2 * Up to
(excluding)
2.9.12-4.fc33
运行在以下环境
系统 fedora_34 libxml2 * Up to
(excluding)
2.9.10-12.fc34
运行在以下环境
系统 opensuse_Leap_15.2 libxml2 * Up to
(excluding)
2.9.7-lp152.10.9.1
运行在以下环境
系统 oracle_8 libxml2 * Up to
(excluding)
2.9.7-9.0.1.el8_4.2
运行在以下环境
系统 redhat_8 libxml2 * Up to
(excluding)
2.9.7-9.el8_4.2
运行在以下环境
系统 suse_12_SP5 libxml2 * Up to
(excluding)
2.9.4-46.43.1
运行在以下环境
系统 ubuntu_14.04 libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.13+esm2
运行在以下环境
系统 ubuntu_16.04 libxml2 * Up to
(excluding)
2.9.3+dfsg1-1ubuntu0.7+esm1
运行在以下环境
系统 ubuntu_18.04 libxml2 * Up to
(excluding)
2.9.4+dfsg1-6.1ubuntu1.4
运行在以下环境
系统 ubuntu_18.04.5_lts libxml2 * Up to
(excluding)
2.9.4+dfsg1-6.1ubuntu1.4
运行在以下环境
系统 ubuntu_20.04 libxml2 * Up to
(excluding)
2.9.10+dfsg-5ubuntu0.20.04.1
运行在以下环境
系统 ubuntu_21.04 libxml2 * Up to
(excluding)
2.9.10+dfsg-6.3ubuntu0.1
阿里云评分
5.6
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况