中危 libxml2缓冲区溢出漏洞(CNVD-2021-37600)

CVE编号

CVE-2021-3517

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-05-19
漏洞描述
libxml2是一款使用C语言编写的用于解析XML文档的函数库。

libxml2中entities.c存在缓冲区溢出漏洞,攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://bugzilla.redhat.com/show_bug.cgi?id=1954232
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat jboss_core_services - -
运行在以下环境
应用 xmlsoft libxml2 * Up to
(excluding)
2.9.11
运行在以下环境
系统 alibaba_cloud_linux_2.1903 libxml2 * Up to
(excluding)
2.9.7-9.1.al8.2
运行在以下环境
系统 alpine_3.10 libxml2 * Up to
(excluding)
2.9.9-r5
运行在以下环境
系统 alpine_3.11 libxml2 * Up to
(excluding)
2.9.10-r5
运行在以下环境
系统 alpine_3.12 libxml2 * Up to
(excluding)
2.9.10-r6
运行在以下环境
系统 alpine_3.13 libxml2 * Up to
(excluding)
2.9.10-r7
运行在以下环境
系统 alpine_3.14 libxml2 * Up to
(excluding)
2.9.11-r0
运行在以下环境
系统 alpine_3.15 libxml2 * Up to
(excluding)
5.15.3_git20211112-r0
运行在以下环境
系统 alpine_edge libxml2 * Up to
(excluding)
2.9.11-r0
运行在以下环境
系统 amazon_2 libxml2 * Up to
(excluding)
2.9.1-6.amzn2.5.3
运行在以下环境
系统 centos_8 libxml2 * Up to
(excluding)
2.9.7-9.el8_4.2
运行在以下环境
系统 debian_10 libxml2 * Up to
(excluding)
2.9.4+dfsg1-7+deb10u2
运行在以下环境
系统 debian_11 libxml2 * Up to
(excluding)
2.9.10+dfsg-6.3
运行在以下环境
系统 debian_9 libxml2 * Up to
(excluding)
2.9.4+dfsg1-2.2+deb9u4
运行在以下环境
系统 debian_sid libxml2 * Up to
(excluding)
2.9.10+dfsg-6.3
运行在以下环境
系统 fedora_33 libxml2 * Up to
(excluding)
2.9.12-4.fc33
运行在以下环境
系统 fedora_34 libxml2 * Up to
(excluding)
2.9.10-12.fc34
运行在以下环境
系统 opensuse_Leap_15.2 libxml2 * Up to
(excluding)
2.9.7-lp152.10.9.1
运行在以下环境
系统 oracle_8 libxml2 * Up to
(excluding)
2.9.7-9.0.1.el8_4.2
运行在以下环境
系统 redhat_8 libxml2 * Up to
(excluding)
2.9.7-9.el8_4.2
运行在以下环境
系统 suse_12_SP5 libxml2 * Up to
(excluding)
2.9.4-46.43.1
运行在以下环境
系统 ubuntu_14.04 libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.13+esm2
运行在以下环境
系统 ubuntu_14.04.6_lts libxml2 * Up to
(excluding)
2.9.1+dfsg1-3ubuntu4.13+esm2
运行在以下环境
系统 ubuntu_16.04 libxml2 * Up to
(excluding)
2.9.3+dfsg1-1ubuntu0.7+esm1
运行在以下环境
系统 ubuntu_18.04 libxml2 * Up to
(excluding)
2.9.4+dfsg1-6.1ubuntu1.4
运行在以下环境
系统 ubuntu_18.04.5_lts libxml2 * Up to
(excluding)
2.9.4+dfsg1-6.1ubuntu1.4
运行在以下环境
系统 ubuntu_20.04 libxml2 * Up to
(excluding)
2.9.10+dfsg-5ubuntu0.20.04.1
运行在以下环境
系统 ubuntu_21.04 libxml2 * Up to
(excluding)
2.9.10+dfsg-6.3ubuntu0.1
阿里云评分
6.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-787 跨界内存写
阿里云安全产品覆盖情况