低危 xmlsoft libxml2 dtd中递归实体索引的不恰当限制(xml实体扩展)

CVE编号

CVE-2021-3541

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-07-10
漏洞描述
A flaw was found in libxml2. Exponential entity expansion attack its possible bypassing all existing protection mechanisms and leading to denial of service.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat jboss_core_services - -
运行在以下环境
应用 xmlsoft libxml2 * Up to
(excluding)
2.9.11
运行在以下环境
系统 alibaba_cloud_linux_2.1903 libxml2 * Up to
(excluding)
2.9.7-9.1.al8.2
运行在以下环境
系统 alpine_3.11 libxml2 * Up to
(excluding)
2.9.12-r0
运行在以下环境
系统 alpine_3.12 libxml2 * Up to
(excluding)
2.9.12-r0
运行在以下环境
系统 alpine_3.13 libxml2 * Up to
(excluding)
2.9.11-r0
运行在以下环境
系统 alpine_3.14 libxml2 * Up to
(excluding)
5.15.3_git20211112-r0
运行在以下环境
系统 alpine_3.15 libxml2 * Up to
(excluding)
5.15.3_git20211112-r0
运行在以下环境
系统 alpine_3.16 libxml2 * Up to
(excluding)
5.15.3_git20211112-r0
运行在以下环境
系统 alpine_edge libxml2 * Up to
(excluding)
2.9.11-r0
运行在以下环境
系统 amazon_2 libxml2 * Up to
(excluding)
2.9.1-6.amzn2.5.3
运行在以下环境
系统 centos_8 libxml2 * Up to
(excluding)
2.9.7-9.el8_4.2
运行在以下环境
系统 debian_10 libxml2 * Up to
(excluding)
2.9.4+dfsg1-7+deb10u2
运行在以下环境
系统 debian_9 libxml2 * Up to
(excluding)
2.9.4+dfsg1-2.2+deb9u5
运行在以下环境
系统 fedora_33 libxml2 * Up to
(excluding)
2.9.12-4.fc33
运行在以下环境
系统 fedora_34 libxml2 * Up to
(excluding)
2.9.12-2.fc34
运行在以下环境
系统 fedora_35 libxml2 * Up to
(excluding)
5.15.8-2.fc35
运行在以下环境
系统 opensuse_Leap_15.2 libxml2 * Up to
(excluding)
2-2.9.7-lp152.10.15.1
运行在以下环境
系统 opensuse_Leap_15.3 libxml2 * Up to
(excluding)
2.9.7-3.37.1
运行在以下环境
系统 oracle_8 libxml2 * Up to
(excluding)
2.9.7-9.0.1.el8_4.2
运行在以下环境
系统 redhat_8 libxml2 * Up to
(excluding)
2.9.7-9.el8_4.2
运行在以下环境
系统 suse_12_SP5 libxml2 * Up to
(excluding)
2-2.9.4-46.46.1
运行在以下环境
系统 ubuntu_20.04 libxml2 * Up to
(excluding)
2.9.10+dfsg-5ubuntu0.20.04.1
运行在以下环境
系统 ubuntu_21.04 libxml2 * Up to
(excluding)
2.9.10+dfsg-6.3ubuntu0.1
运行在以下环境
系统 ubuntu_8 libxml2 * Up to
(excluding)
2.9.7-9.el8_4.2
阿里云评分
3.7
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-776 DTD中递归实体索引的不恰当限制(XML实体扩展)
阿里云安全产品覆盖情况