openvpn openvpn 认证机制不恰当

CVE编号

CVE-2021-3547

利用情况

暂无

补丁情况

N/A

披露时间

2021-07-12
漏洞描述
OpenVPN 3 Core Library version 3.6 and 3.6.1 allows a man-in-the-middle attacker to bypass the certificate authentication by issuing an unrelated server certificate using the same hostname found in the verify-x509-name option in a client configuration.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openvpn openvpn 3.6 -
运行在以下环境
应用 openvpn openvpn 3.6.1 -
运行在以下环境
系统 amazon_2 linux * Up to
(excluding)
4.14.241-184.433.amzn2
运行在以下环境
系统 debian_10 linux * Up to
(excluding)
8.0.2+ds-1+deb10u5
运行在以下环境
系统 debian_11 linux * Up to
(excluding)
8.1.1+ds-1
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.228-1
运行在以下环境
系统 debian_sid linux * Up to
(excluding)
8.1.1+ds-1
运行在以下环境
系统 fedora_33 linux * Up to
(excluding)
5.13.8-100.fc33
运行在以下环境
系统 fedora_34 linux * Up to
(excluding)
5.13.8-200.fc34
运行在以下环境
系统 opensuse_Leap_15.2 kernel * Up to
(excluding)
5.3.18-lp152.92.1
运行在以下环境
系统 opensuse_Leap_15.3 kernel * Up to
(excluding)
5.3.18-38.22.2
运行在以下环境
系统 suse_12_SP5 kernel * Up to
(excluding)
4.12.14-122.88.1
运行在以下环境
系统 ubuntu_18.04.5_lts linux-aws-5.4 * Up to
(excluding)
5.4.0-1059.62~18.04.1
CVSS3评分
7.4
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
阿里云安全产品覆盖情况