中危 Red Hat libvirt 缓冲区错误漏洞

CVE编号

CVE-2021-3559

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-05-24
漏洞描述
Red Hat libvirt是美国红帽(Red Hat)公司的一个用于实现Linux虚拟化功能的Linux API,它支持各种Hypervisor,包括Xen和KVM,以及QEMU和用于其他操作系统的一些虚拟产品。

libvirt 存在安全漏洞,该漏洞只影响具有支持中介设备(例如,GRID驱动程序)的PCI设备和驱动程序的主机。使用只读连接的非特权客户端可以使用这个缺陷,通过执行“nodedev-list” virsh命令使libvirt守护进程崩溃。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://bugzilla.redhat.com/show_bug.cgi?id=1962306
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat libvirt * From
(including)
6.10.0
Up to
(excluding)
7.0.0
运行在以下环境
系统 fedora_33 mysql * Up to
(excluding)
8.0.27-1.fc33
运行在以下环境
系统 fedora_33_Modular mysql * Up to
(excluding)
8.0-3320211031142409.601d93de
运行在以下环境
系统 fedora_34 mysql * Up to
(excluding)
8.0.27-1.fc34
运行在以下环境
系统 fedora_34_Modular mysql * Up to
(excluding)
8.0-3420211031142409.058368ca
运行在以下环境
系统 fedora_35 mysql * Up to
(excluding)
8.0.27-1.fc35
运行在以下环境
系统 fedora_35_Modular mysql * Up to
(excluding)
8.0-3520211031142409.f27b74a8
运行在以下环境
系统 ubuntu_18.04.5_lts libvirt * Up to
(excluding)
4.0.0-1ubuntu8.19
阿里云评分
5.0
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    N/A
  • 数据完整性
    N/A
  • 服务器危害
    N/A
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况