低危 Red Hat Ansible 命令注入漏洞

CVE编号

CVE-2021-3583

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-09-23
漏洞描述
Red Hat Ansible是美国红帽(Red Hat)公司的一款计算机系统配置管理器。该产品可用于发布、管理和编排计算机系统。
Ansible 中存在命令注入漏洞,该漏洞源于将模板放入多行 YAML 字符串中并且存在特殊字符时,可能导致命令注入导致信息泄露。
解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://www.redhat.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 debian_10 ansible * Up to
(excluding)
2.7.7+dfsg-1+deb10u1
运行在以下环境
系统 debian_11 ansible * Up to
(excluding)
2.10.7+merged+base+2.10.8+dfsg-1
运行在以下环境
系统 debian_12 ansible * Up to
(excluding)
2.10.7+merged+base+2.10.8+dfsg-1
运行在以下环境
系统 debian_9 ansible * Up to
(excluding)
2.2.1.0-2+deb9u1
运行在以下环境
系统 debian_sid ansible * Up to
(excluding)
2.10.7+merged+base+2.10.8+dfsg-1
运行在以下环境
系统 fedora_33 ansible * Up to
(excluding)
2.9.23-1.fc33
运行在以下环境
系统 fedora_34 ansible * Up to
(excluding)
2.9.23-1.fc34
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.23-1.el7
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.23-1.el8
阿里云评分
3.1
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
CWE-77 在命令中使用的特殊元素转义处理不恰当(命令注入)
阿里云安全产品覆盖情况