低危 Apache Portable Runtime 安全漏洞

CVE编号

CVE-2021-35940

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2021-08-23
漏洞描述
Apache Portable Runtime(APR,Apache可移植运行库)是美国阿帕奇(Apache)基金会的一个为上层应用程序提供可跨越多个操作系统平台使用的底层支持接口库。
Apache Portable Runtime 1.7.0版本存在安全漏洞,该漏洞源于软件中apr_time_exp*()函数中超出边界的数组读取问题。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://lists.apache.org/thread.html/ra2868b53339a6af65577146ad87016368c138388b09bff9d2860f50e%40%3Cdev.apr.apache.org%3E
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache portable_runtime * Up to
(excluding)
1.7.0
运行在以下环境
系统 alpine_3.13 apr * Up to
(excluding)
1.7.0-r1
运行在以下环境
系统 alpine_3.14 apr * Up to
(excluding)
1.7.0-r1
运行在以下环境
系统 alpine_3.15 apr * Up to
(excluding)
1.7.0-r1
运行在以下环境
系统 alpine_3.16 apr * Up to
(excluding)
1.7.0-r2
运行在以下环境
系统 alpine_edge apr * Up to
(excluding)
1.7.0-r2
运行在以下环境
系统 debian_11 apr * Up to
(excluding)
1.7.0-6+deb11u1
运行在以下环境
系统 ubuntu_14.04 apr * Up to
(excluding)
1.5.0-1ubuntu0.1~esm1
运行在以下环境
系统 ubuntu_16.04 apr * Up to
(excluding)
1.5.2-3ubuntu0.1~esm1
运行在以下环境
系统 ubuntu_21.04 apr * Up to
(excluding)
1.7.0-6ubuntu0.1
运行在以下环境
系统 ubuntu_21.10 apr * Up to
(excluding)
1.7.0-6ubuntu1
运行在以下环境
系统 ubuntu_22.04 apr * Up to
(excluding)
1.7.0-6ubuntu1
阿里云评分
3.5
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况