低危 alpine_3.14 buildah 信息暴露

CVE编号

CVE-2021-3602

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-07-19
漏洞描述
When running processes using "chroot" isolation, the process being run can examine the environment variables of its immediate parent and grandparent processes (CVE-2021-3602). This isolation type is often used when running buildah in unprivileged containers, and it is often used to do so in CI/CD environments. If sensitive information is exposed to the original buildah process through its environment, that information will unintentionally be shared with child processes which it starts as part of handling RUN instructions or during buildah run. The commands that buildah is instructed to run can read that information if they choose to.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 buildah_project buildah * Up to
(excluding)
1.16.8
运行在以下环境
应用 buildah_project buildah * From
(including)
1.17.0
Up to
(excluding)
1.17.2
运行在以下环境
应用 buildah_project buildah * From
(including)
1.19.0
Up to
(excluding)
1.19.9
运行在以下环境
应用 buildah_project buildah * From
(including)
1.21.0
Up to
(excluding)
1.21.3
运行在以下环境
系统 alpine_3.14 buildah * Up to
(excluding)
3.2.3-r0
运行在以下环境
系统 alpine_3.15 buildah * Up to
(excluding)
1.21.3-r0
运行在以下环境
系统 alpine_3.16 buildah * Up to
(excluding)
3.2.3-r0
运行在以下环境
系统 alpine_3.17 buildah * Up to
(excluding)
3.2.3-r0
运行在以下环境
系统 alpine_edge buildah * Up to
(excluding)
3.2.3-r0
运行在以下环境
系统 debian_11 buildah * Up to
(including)
1.19.6+dfsg1-1
运行在以下环境
系统 debian_12 buildah * Up to
(including)
1.23.1+ds1-3
运行在以下环境
系统 debian_sid buildah * Up to
(including)
1.23.1+ds1-3
运行在以下环境
系统 fedora_33 buildah * Up to
(excluding)
1.21.4-4.fc33
运行在以下环境
系统 fedora_34 buildah * Up to
(excluding)
1.21.4-4.fc34
运行在以下环境
系统 opensuse_Leap_15.3 buildah * Up to
(excluding)
2.5.3-150300.10.5.1
运行在以下环境
系统 oracle_8 buildah * Up to
(excluding)
2.0.15-1.module+el8.5.0+20355+d36cb39d
运行在以下环境
系统 redhat enterprise_linux 8.0 -
运行在以下环境
系统 redhat enterprise_linux_for_ibm_z_systems 8.0 -
运行在以下环境
系统 redhat enterprise_linux_for_power_little_endian 8.0 -
阿里云评分
3.4
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-200 信息暴露
CWE-212 敏感数据的不恰当跨边界移除
阿里云安全产品覆盖情况