中危 linux linux_kernel 内存缓冲区边界内操作的限制不恰当

CVE编号

CVE-2021-3612

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-07-09
漏洞描述
An out-of-bounds memory write flaw was found in the Linux kernel's joystick devices subsystem in versions before 5.9-rc1, in the way the user calls ioctl JSIOCSBTNMAP. This flaw allows a local user to crash the system or possibly escalate their privileges on the system. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 debian_10 linux * Up to
(excluding)
4.19.208-1
运行在以下环境
系统 debian_11 linux * Up to
(excluding)
5.10.40-1
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.290-1
运行在以下环境
系统 debian_sid linux * Up to
(excluding)
5.10.46-1
运行在以下环境
系统 fedoraproject fedora 34 -
运行在以下环境
系统 fedora_34 linux * Up to
(excluding)
5.12.17-300.fc34
运行在以下环境
系统 linux linux_kernel * Up to
(excluding)
5.9.0
运行在以下环境
系统 linux linux_kernel 5.9.0 -
运行在以下环境
系统 opensuse_Leap_15.2 linux * Up to
(excluding)
5.3.18-lp152.84.1.lp152.8.38.1
运行在以下环境
系统 opensuse_Leap_15.3 linux * Up to
(excluding)
5.3.18-38.17.1
运行在以下环境
系统 opensuse_Leap_15.3 linux * Up to
(excluding)
5.3.18-59.19.1.18.10.1
运行在以下环境
系统 oracle_7 linux * Up to
(excluding)
4.14.35-2047.507.7.4.el7
运行在以下环境
系统 redhat enterprise_linux 7.0 -
运行在以下环境
系统 redhat enterprise_linux 8.0 -
运行在以下环境
系统 suse_12_SP5 linux * Up to
(excluding)
4.12.14-122.80.1
运行在以下环境
系统 suse_12_SP5 linux * Up to
(excluding)
4.12.14-16.65.1
运行在以下环境
系统 ubuntu_14.04 linux * Up to
(excluding)
4.15.0-1123.136~14.04.1
运行在以下环境
系统 ubuntu_16.04 linux * Up to
(excluding)
4.15.0-1080.88~16.04.1
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
5.4.0-1023.24~18.04.1
运行在以下环境
系统 ubuntu_20.04 linux * Up to
(excluding)
5.4.0-1058.60
运行在以下环境
系统 ubuntu_21.04 linux * Up to
(excluding)
5.11.0-1018.20
阿里云评分
5.1
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    N/A
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况