低危 libcares2 安全漏洞

CVE编号

CVE-2021-3672

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-08-10 00:00:00
漏洞描述
libcares2是openSUSE项目的一个 C 库,可以异步执行 DNS 请求和名称解析。
libcares2 存在安全漏洞,该漏洞源于对主机名的输入验证不当。
解决建议
这个缺陷存在于以下版本的c-ares。
-受影响的版本:c-ares 1.0.0到1.17.1
-不受影响的版本:c-ares >= 1.17.2
补丁
https://github.com/c-ares/c-ares/compare/809d5e8..44c009b.patch
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 c-ares_project c-ares * From
(including)
1.0.0
Up to
(excluding)
1.17.2
运行在以下环境
系统 alibaba_cloud_linux_2.1903 c-ares * Up to
(excluding)
14.17.5-1.1.al8
运行在以下环境
系统 alpine_3.11 c-ares * Up to
(excluding)
12.22.5-r0
运行在以下环境
系统 alpine_3.12 c-ares * Up to
(excluding)
12.22.5-r0
运行在以下环境
系统 alpine_3.13 c-ares * Up to
(excluding)
14.17.5-r0
运行在以下环境
系统 alpine_3.14 c-ares * Up to
(excluding)
14.17.5-r0
运行在以下环境
系统 alpine_3.15 c-ares * Up to
(excluding)
16.6.2-r0
运行在以下环境
系统 alpine_edge c-ares * Up to
(excluding)
16.6.2-r0
运行在以下环境
系统 amazon_AMI c-ares * Up to
(excluding)
1.17.2-1.8.amzn1
运行在以下环境
系统 centos_8 c-ares * Up to
(excluding)
14.17.5-1.module+el8.4.0+12247+e2879e58
运行在以下环境
系统 debian_10 c-ares * Up to
(excluding)
1.14.0-1+deb10u1
运行在以下环境
系统 debian_11 c-ares * Up to
(excluding)
1.17.1-1+deb11u1
运行在以下环境
系统 debian_9 c-ares * Up to
(excluding)
1.12.0-1+deb9u2
运行在以下环境
系统 fedora_33 c-ares * Up to
(excluding)
1.17.2-1.fc33
运行在以下环境
系统 fedora_34 c-ares * Up to
(excluding)
1.17.2-1.fc34
运行在以下环境
系统 fedora_35 c-ares * Up to
(excluding)
4.0.0-5.fc35
运行在以下环境
系统 opensuse_Leap_15.2 c-ares * Up to
(excluding)
1.17.1
运行在以下环境
系统 opensuse_Leap_15.2 c-ares * Up to
(excluding)
10.24.1-lp152.2.18.1
运行在以下环境
系统 opensuse_Leap_15.2 c-ares * Up to
(excluding)
12.22.5-lp152.3.18.1
运行在以下环境
系统 opensuse_Leap_15.3 c-ares * Up to
(excluding)
1.17.1
运行在以下环境
系统 opensuse_Leap_15.3 c-ares * Up to
(excluding)
10.24.1-1.39.2
运行在以下环境
系统 opensuse_Leap_15.3 c-ares * Up to
(excluding)
12.22.5-4.19.1
运行在以下环境
系统 opensuse_Leap_15.3 c-ares * Up to
(excluding)
14.17.5-5.15.5
运行在以下环境
系统 oracle_8 c-ares * Up to
(excluding)
12.22.5-1.module+el8.4.0+20308+065a70e3
运行在以下环境
系统 redhat_8 c-ares * Up to
(excluding)
2.0.3-1.module+el8.3.0+6519+9f98ed83
运行在以下环境
系统 suse_12_SP5 c-ares * Up to
(excluding)
1.9.1-9.7.1
运行在以下环境
系统 ubuntu_16.04 c-ares * Up to
(excluding)
1.10.0-3ubuntu0.2+esm1
运行在以下环境
系统 ubuntu_18.04 c-ares * Up to
(excluding)
1.14.0-1ubuntu0.1
运行在以下环境
系统 ubuntu_20.04 c-ares * Up to
(excluding)
1.15.0-1ubuntu0.1
运行在以下环境
系统 ubuntu_21.04 c-ares * Up to
(excluding)
1.17.1-1ubuntu0.1
阿里云评分
2.5
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况