中危 Vim 缓冲区错误漏洞

CVE编号

CVE-2021-3770

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-09-06
漏洞描述
Vim是一款基于UNIX平台的编辑器。

vim 存在缓冲区错误漏洞,该漏洞源于vim软件中使用retab的值较大时内存访问无效,从而导致基于堆的缓冲区溢出。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/vim/vim/commit/b7081e135a16091c93f6f5f7525a5c58fb7ca9f9
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(excluding)
8.2.3408
运行在以下环境
系统 alpine_3.11 vim * Up to
(excluding)
8.2.3437-r0
运行在以下环境
系统 alpine_3.12 vim * Up to
(excluding)
8.2.3437-r0
运行在以下环境
系统 alpine_3.13 vim * Up to
(excluding)
8.2.3437-r0
运行在以下环境
系统 alpine_3.14 vim * Up to
(excluding)
8.2.3437-r0
运行在以下环境
系统 alpine_3.15 vim * Up to
(excluding)
8.2.3437-r0
运行在以下环境
系统 alpine_3.16 vim * Up to
(excluding)
8.2.3437-r0
运行在以下环境
系统 alpine_edge vim * Up to
(excluding)
8.2.3437-r0
运行在以下环境
系统 debian_10 vim * Up to
(excluding)
2:8.1.0875-5+deb10u1
运行在以下环境
系统 debian_11 vim * Up to
(excluding)
2:8.2.2434-3+deb11u1
运行在以下环境
系统 debian_12 vim * Up to
(including)
8.2.2434-3
运行在以下环境
系统 debian_9 vim * Up to
(including)
8.0.0197-4+deb9u3
运行在以下环境
系统 debian_sid vim * Up to
(including)
8.2.2434-3
运行在以下环境
系统 fedora_33 vim * Up to
(excluding)
8.2.3404-1.fc33
运行在以下环境
系统 fedora_34 vim * Up to
(excluding)
8.2.3404-1.fc34
运行在以下环境
系统 fedora_35 vim * Up to
(excluding)
8.2.3404-1.fc35
运行在以下环境
系统 opensuse_Leap_15.2 vim * Up to
(excluding)
14.18.1-lp152.17.1
运行在以下环境
系统 opensuse_Leap_15.3 vim * Up to
(excluding)
12.22.7-4.22.1
运行在以下环境
系统 oracle_8 vim * Up to
(excluding)
23-3.module+el8.3.0+7818+6cd30d85
运行在以下环境
系统 ubuntu_20.04 vim * Up to
(excluding)
2:8.1.2269-1ubuntu5.3
运行在以下环境
系统 ubuntu_21.04 vim * Up to
(excluding)
2:8.2.2434-1ubuntu1.1
运行在以下环境
系统 ubuntu_21.10 vim * Up to
(excluding)
2:8.2.2434-3ubuntu2
运行在以下环境
系统 ubuntu_22.04 vim * Up to
(excluding)
2:8.2.2434-3ubuntu2
阿里云评分
6.7
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况