中危 Npm Node-tar 后置链接漏洞

CVE编号

CVE-2021-37701

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-09-01
漏洞描述
node-tar是一款用于文件压缩/解压缩的软件包。

Npm Node-tar 中存在后置链接漏洞,该漏洞源于产品未对特殊字符做有效验证。攻击者可通过该漏洞在其他路径创建恶意文件。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/npm/node-tar/security/advisories/GHSA-9r2w-394v-53qc
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 npmjs tar * Up to
(excluding)
4.4.17
运行在以下环境
应用 npmjs tar * From
(including)
5.0.0
Up to
(excluding)
5.0.9
运行在以下环境
应用 npmjs tar * From
(including)
6.0.0
Up to
(excluding)
6.1.8
运行在以下环境
系统 alpine_3.11 nodejs * Up to
(excluding)
12.22.6-r0
运行在以下环境
系统 alpine_3.12 nodejs * Up to
(excluding)
12.22.6-r0
运行在以下环境
系统 alpine_3.13 nodejs * Up to
(excluding)
14.17.6-r0
运行在以下环境
系统 alpine_3.14 nodejs * Up to
(excluding)
14.17.6-r0
运行在以下环境
系统 alpine_3.15 nodejs * Up to
(excluding)
14.17.6-r0
运行在以下环境
系统 alpine_3.16 nodejs * Up to
(excluding)
14.17.6-r0
运行在以下环境
系统 alpine_edge nodejs * Up to
(excluding)
14.17.6-r0
运行在以下环境
系统 debian_10 nodejs * Up to
(including)
4.4.6+ds1-3+deb10u1
运行在以下环境
系统 debian_11 nodejs * Up to
(excluding)
6.0.5+ds1+~cs11.3.9-1+deb11u2
运行在以下环境
系统 debian_9 nodejs * Up to
(including)
2.2.1-1
运行在以下环境
系统 opensuse_Leap_15.2 nodejs * Up to
(excluding)
14.18.1-lp152.17.1
运行在以下环境
系统 opensuse_Leap_15.3 nodejs * Up to
(excluding)
12.22.7-4.22.1
运行在以下环境
系统 oracle_8 nodejs * Up to
(excluding)
23-3.module+el8.3.0+7818+6cd30d85
阿里云评分
4.5
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-22 对路径名的限制不恰当(路径遍历)
CWE-59 在文件访问前对链接解析不恰当(链接跟随)
阿里云安全产品覆盖情况