pi-hole web_interface 在web页面生成时对输入的转义处理不恰当(跨站脚本)

CVE编号

CVE-2021-3811

利用情况

暂无

补丁情况

N/A

披露时间

2021-09-17
漏洞描述
adminlte is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 pi-hole web_interface * Up to
(excluding)
5.6
运行在以下环境
系统 alpine_3.11 gd * Up to
(excluding)
2.2.5-r4
运行在以下环境
系统 alpine_3.12 gd * Up to
(excluding)
2.3.0-r1
运行在以下环境
系统 alpine_3.13 gd * Up to
(excluding)
2.3.0-r1
运行在以下环境
系统 alpine_3.14 gd * Up to
(excluding)
2.3.0-r1
运行在以下环境
系统 alpine_edge gd * Up to
(excluding)
2.3.0-r1
运行在以下环境
系统 debian_10 gd * Up to
(excluding)
7:4.1.8-0+deb10u1
运行在以下环境
系统 debian_11 gd * Up to
(excluding)
7:4.3.3-0+deb11u1
运行在以下环境
系统 debian_12 gd * Up to
(excluding)
4.4-6
运行在以下环境
系统 debian_9 gd * Up to
(excluding)
7:3.2.15-0+deb9u3
运行在以下环境
系统 debian_sid gd * Up to
(excluding)
4.4.1-1
运行在以下环境
系统 opensuse_Leap_15.3 gd * Up to
(excluding)
3.4.2-11.8.2
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.11+esm2
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.12+esm1
运行在以下环境
系统 ubuntu_18.04 gd * Up to
(excluding)
2.2.5-4ubuntu0.5
运行在以下环境
系统 ubuntu_18.04.5_lts libgd2 * Up to
(excluding)
2.2.5-4ubuntu0.5
运行在以下环境
系统 ubuntu_20.04 gd * Up to
(excluding)
2.2.5-5.2ubuntu2.1
运行在以下环境
系统 ubuntu_21.04 gd * Up to
(excluding)
2.3.0-2ubuntu0.1
CVSS3评分
6.1
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况