中危 Mozilla Firefox 缓冲区错误漏洞

CVE编号

CVE-2021-38493

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-09-15
漏洞描述
Mozilla Firefox是美国Mozilla基金会的一款开源Web浏览器。
Mozilla Firefox 中存在缓冲区错误漏洞,该漏洞源于产品处理HTML内容时出现边界错误。远程攻击者可利用该漏洞可以创建一个专门制作的网页,诱骗受害者打开它,引发内存损坏,并在目标系统上执行任意代码。
解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://www.mozilla.org/en-US/security/advisories/mfsa2021-38/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mozilla firefox * Up to
(excluding)
92.0
运行在以下环境
应用 mozilla firefox_esr * Up to
(excluding)
78.14
运行在以下环境
应用 mozilla thunderbird * Up to
(excluding)
78.14
运行在以下环境
系统 alpine_3.13 mozjs78 * Up to
(excluding)
78.14.0-r0
运行在以下环境
系统 alpine_3.14 mozjs78 * Up to
(excluding)
78.14.0-r0
运行在以下环境
系统 alpine_3.15 firefox * Up to
(excluding)
78.14.0-r0
运行在以下环境
系统 alpine_3.16 firefox * Up to
(excluding)
91.3.2-r0
运行在以下环境
系统 alpine_edge mozjs78 * Up to
(excluding)
92.0.1-r0
运行在以下环境
系统 amazon_2 mozjs78 * Up to
(excluding)
78.14.0-1.amzn2.0.1
运行在以下环境
系统 centos_7 mozjs78 * Up to
(excluding)
78.14.0-1.el7.centos
运行在以下环境
系统 centos_8 mozjs78 * Up to
(excluding)
78.14.0-1.el8_4
运行在以下环境
系统 debian_10 mozjs78 * Up to
(excluding)
1:78.14.0-1~deb10u1
运行在以下环境
系统 debian_11 mozjs78 * Up to
(excluding)
78.14.0esr-1~deb11u1
运行在以下环境
系统 debian_12 mozjs78 * Up to
(including)
78.13.0esr-1
运行在以下环境
系统 debian_9 mozjs78 * Up to
(excluding)
1:78.14.0-1~deb9u1
运行在以下环境
系统 opensuse_Leap_15.2 firefox * Up to
(excluding)
91.4.0-lp152.2.52.1
运行在以下环境
系统 opensuse_Leap_15.3 firefox * Up to
(excluding)
91.4.0-8.45.2
运行在以下环境
系统 oracle_7 mozjs78 * Up to
(excluding)
78.14.0-1.0.1.el7_9
运行在以下环境
系统 oracle_8 mozjs78 * Up to
(excluding)
78.14.0-1.0.1.el8_4
运行在以下环境
系统 redhat_7 thunderbird * Up to
(excluding)
0:78.14.0-1.el7_9
运行在以下环境
系统 redhat_8 mozjs78 * Up to
(excluding)
78.14.0-1.el8_4
运行在以下环境
系统 ubuntu_18.04 mozjs78 * Up to
(excluding)
92.0+build3-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts firefox * Up to
(excluding)
92.0+build3-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_20.04 mozjs78 * Up to
(excluding)
92.0+build3-0ubuntu0.20.04.1
运行在以下环境
系统 ubuntu_21.04 mozjs78 * Up to
(excluding)
92.0+build3-0ubuntu0.21.04.1
运行在以下环境
系统 ubuntu_21.10 firefox * Up to
(excluding)
92.0+build3-0ubuntu1
运行在以下环境
系统 ubuntu_22.04 firefox * Up to
(excluding)
92.0+build3-0ubuntu1
阿里云评分
6.2
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-787 跨界内存写
阿里云安全产品覆盖情况