中危 Vim 缓冲区错误漏洞

CVE编号

CVE-2021-3875

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-10-15
漏洞描述
Vim是一款基于UNIX平台的编辑器。

vim 存在安全漏洞,该漏洞源于基于堆的缓冲区溢出。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://github.com/vim/vim/commit/35a319b77f897744eec1155b736e9372c9c5575f
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(excluding)
8.2.3489
运行在以下环境
系统 alpine_3.12 vim * Up to
(excluding)
8.2.3500-r0
运行在以下环境
系统 alpine_3.13 vim * Up to
(excluding)
8.2.3500-r0
运行在以下环境
系统 alpine_3.14 vim * Up to
(excluding)
8.2.3500-r0
运行在以下环境
系统 alpine_3.15 vim * Up to
(excluding)
8.2.3500-r0
运行在以下环境
系统 alpine_3.16 vim * Up to
(excluding)
8.2.3500-r0
运行在以下环境
系统 alpine_edge vim * Up to
(excluding)
8.2.3500-r0
运行在以下环境
系统 amazon_2 vim * Up to
(excluding)
8.2.3642-1.amzn2.0.1
运行在以下环境
系统 fedora_33 vim * Up to
(excluding)
8.2.3512-1.fc33
运行在以下环境
系统 fedora_34 vim * Up to
(excluding)
8.2.3512-1.fc34
运行在以下环境
系统 fedora_35 vim * Up to
(excluding)
8.2.3512-1.fc35
运行在以下环境
系统 ubuntu_18.04 vim * Up to
(excluding)
2:8.0.1453-1ubuntu1.6
运行在以下环境
系统 ubuntu_18.04.5_lts vim * Up to
(excluding)
2:8.0.1453-1ubuntu1.6
运行在以下环境
系统 ubuntu_22.04 vim * Up to
(excluding)
2:8.2.3565-1ubuntu2
阿里云评分
5.5
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-122 堆缓冲区溢出
CWE-787 跨界内存写
阿里云安全产品覆盖情况