高危 XStream < 1.4.18 任意代码执行

CVE编号

CVE-2021-39151

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2021-08-24
漏洞描述
XStream是XStream(Xstream)团队的一个轻量级的、简单易用的开源Java类库,它主要用于将对象序列化成XML(JSON)或反序列化为对象。
XStream 1.4.18之前版本存在代码问题漏洞,攻击者可利用该漏洞通过操纵已处理的输入流从远程主机加载和执行任意代码
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://x-stream.github.io/CVE-2021-39151.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 xstream_project xstream * Up to
(excluding)
1.4.18
运行在以下环境
系统 debian_10 xstream * Up to
(excluding)
1.4.11.1-1+deb10u3
运行在以下环境
系统 debian_11 xstream * Up to
(excluding)
1.4.15-3+deb11u1
运行在以下环境
系统 debian_9 xstream * Up to
(excluding)
1.4.11.1-1+deb9u4
运行在以下环境
系统 fedora_33 xstream * Up to
(excluding)
1.4.18-2.fc33
运行在以下环境
系统 fedora_34 xstream * Up to
(excluding)
1.4.18-2.fc34
运行在以下环境
系统 fedora_35 xstream * Up to
(excluding)
1.4.18-2.fc35
运行在以下环境
系统 opensuse_Leap_15.2 xstream * Up to
(excluding)
1.4.18-lp152.2.12.1
运行在以下环境
系统 opensuse_Leap_15.3 xstream * Up to
(excluding)
1.4.18-3.14.1
阿里云评分
8.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-434 危险类型文件的不加限制上传
CWE-502 可信数据的反序列化
阿里云安全产品覆盖情况