中危 imagemagick imagemagick 将资源暴露给错误范围

CVE编号

CVE-2021-39212

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-09-14
漏洞描述
ImageMagick is free software delivered as a ready-to-run binary distribution or as source code that you may use, copy, modify, and distribute in both open and proprietary applications. In affected versions and in certain cases, Postscript files could be read and written when specifically excluded by a `module` policy in `policy.xml`. ex. <policy domain="module" rights="none" pattern="PS" />. The issue has been resolved in ImageMagick 7.1.0-7 and in 6.9.12-22. Fortunately, in the wild, few users utilize the `module` policy and instead use the `coder` policy that is also our workaround recommendation: <policy domain="coder" rights="none" pattern="{PS,EPI,EPS,EPSF,EPSI}" />.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick imagemagick * From
(including)
6.9.12-0
Up to
(excluding)
6.9.12-22
运行在以下环境
应用 imagemagick imagemagick * From
(including)
7.1.0-0
Up to
(excluding)
7.1.0-7
运行在以下环境
系统 alpine_3.15 imagemagick * Up to
(excluding)
7.1.0.10-r0
运行在以下环境
系统 alpine_3.16 imagemagick * Up to
(excluding)
7.1.0.10-r0
运行在以下环境
系统 alpine_edge imagemagick * Up to
(excluding)
6.9.12.31-r0
运行在以下环境
系统 debian_10 imagemagick * Up to
(including)
6.9.10.23+dfsg-2.1+deb10u1
运行在以下环境
系统 debian_11 imagemagick * Up to
(including)
6.9.11.60+dfsg-1.3
运行在以下环境
系统 debian_12 imagemagick * Up to
(including)
6.9.11.60+dfsg-1.3
运行在以下环境
系统 debian_9 imagemagick * Up to
(including)
6.9.7.4+dfsg-11+deb9u8
运行在以下环境
系统 debian_sid imagemagick * Up to
(including)
6.9.11.60+dfsg-1.3
运行在以下环境
系统 fedora_EPEL_8 imagemagick * Up to
(excluding)
0.9.8.1-2.el8
阿里云评分
5.7
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-362 使用共享资源的并发执行不恰当同步问题(竞争条件)
CWE-668 将资源暴露给错误范围
阿里云安全产品覆盖情况