高危 haproxy <= 2.2.15/2.3.12/2.4.2 对异常条件的处理不恰当

CVE编号

CVE-2021-39242

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2021-08-18
漏洞描述
An issue was discovered in HAProxy 2.2 before 2.2.16, 2.3 before 2.3.13, and 2.4 before 2.4.3. It can lead to a situation with an attacker-controlled HTTP Host header, because a mismatch between Host and authority is mishandled.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haproxy haproxy * From
(including)
2.2.0
Up to
(excluding)
2.2.16
运行在以下环境
应用 haproxy haproxy * From
(including)
2.3.0
Up to
(excluding)
2.3.13
运行在以下环境
应用 haproxy haproxy * From
(including)
2.4.0
Up to
(excluding)
2.4.3
运行在以下环境
系统 debian_11 haproxy * Up to
(excluding)
2.2.9-2+deb11u1
运行在以下环境
系统 fedora_33 haproxy * Up to
(excluding)
2.2.16-1.fc33
运行在以下环境
系统 fedora_34 haproxy * Up to
(excluding)
2.3.13-1.fc34
运行在以下环境
系统 ubuntu_21.04 haproxy * Up to
(excluding)
2.2.9-1ubuntu0.1
阿里云评分
7.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-755 对异常条件的处理不恰当
阿里云安全产品覆盖情况