中危 Apache HTTP Server 安全漏洞

CVE编号

CVE-2021-39275

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-09-17
漏洞描述
Apache HTTP Server是美国阿帕奇(Apache)基金会的一款开源网页服务器。该服务器具有快速、可靠且可通过简单的API进行扩充的特点。
Apache HTTP Server 2.4.48及之前版本存在安全漏洞,该漏洞源于当给定恶意输入时,ap_escape_quotes()可能会写入缓冲区之外的内容。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://httpd.apache.org/security/vulnerabilities_24.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * Up to
(including)
2.4.48
运行在以下环境
系统 alibaba_cloud_linux_2.1903 httpd * Up to
(excluding)
2.4.6-97.1.al7.4
运行在以下环境
系统 alpine_3.11 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.12 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.13 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.14 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.15 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.16 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_edge httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.51-1.amzn2
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.51-1.94.amzn1
运行在以下环境
系统 centos_7 httpd * Up to
(excluding)
2.4.6-97.el7.centos.4
运行在以下环境
系统 debian_10 apache2 * Up to
(excluding)
2.4.38-3+deb10u6
运行在以下环境
系统 debian_11 apache2 * Up to
(excluding)
2.4.51-1~deb11u1
运行在以下环境
系统 debian_12 apache2 * Up to
(including)
2.4.48-4
运行在以下环境
系统 debian_9 apache2 * Up to
(excluding)
2.4.25-3+deb9u11
运行在以下环境
系统 fedoraproject fedora 34 -
运行在以下环境
系统 fedoraproject fedora 35 -
运行在以下环境
系统 fedora_34 apache2 * Up to
(excluding)
2.4.49-1.fc34
运行在以下环境
系统 fedora_35 apache2 * Up to
(excluding)
2.4.49-1.fc35
运行在以下环境
系统 opensuse_Leap_15.2 httpd * Up to
(excluding)
2.4.43-lp152.2.21.1
运行在以下环境
系统 opensuse_Leap_15.3 httpd * Up to
(excluding)
2.4.43-3.32.1
运行在以下环境
系统 oracle_7 httpd * Up to
(excluding)
2.4.6-97.0.5.el7_9.2
运行在以下环境
系统 oracle_8 httpd * Up to
(excluding)
2.4.37-43.0.2.module+el8.5.0+20470+f38d0c8f
运行在以下环境
系统 redhat_7 httpd * Up to
(excluding)
0:2.4.6-97.el7_9.4
运行在以下环境
系统 suse_12_SP5 httpd * Up to
(excluding)
2.4.23-29.80.1
运行在以下环境
系统 ubuntu_14.04 httpd * Up to
(excluding)
2.4.7-1ubuntu4.22+esm2
运行在以下环境
系统 ubuntu_16.04 httpd * Up to
(excluding)
2.4.18-2ubuntu3.17+esm2
运行在以下环境
系统 ubuntu_18.04 httpd * Up to
(excluding)
2.4.29-1ubuntu4.17
运行在以下环境
系统 ubuntu_18.04.5_lts apache2 * Up to
(excluding)
2.4.29-1ubuntu4.17
运行在以下环境
系统 ubuntu_20.04 httpd * Up to
(excluding)
2.4.41-4ubuntu3.5
运行在以下环境
系统 ubuntu_21.04 httpd * Up to
(excluding)
2.4.46-4ubuntu1.2
运行在以下环境
系统 ubuntu_21.10 httpd * Up to
(excluding)
2.4.48-3.1ubuntu2
运行在以下环境
系统 ubuntu_22.04 httpd * Up to
(excluding)
2.4.48-3.1ubuntu2
阿里云评分
4.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-120 未进行输入大小检查的缓冲区拷贝(传统缓冲区溢出)
CWE-787 跨界内存写
阿里云安全产品覆盖情况