vim vim 堆缓冲区溢出

CVE编号

CVE-2021-3984

利用情况

暂无

补丁情况

N/A

披露时间

2021-12-01
漏洞描述
vim is vulnerable to Heap-based Buffer Overflow
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(including)
8.2.3625
运行在以下环境
系统 alpine_edge vim * Up to
(excluding)
8.2.3650-r0
运行在以下环境
系统 amazon_AMI vim * Up to
(excluding)
8.2.4006-1.1.amzn1
运行在以下环境
系统 debian_10 vim * Up to
(excluding)
8.1.0875-5
运行在以下环境
系统 debian_11 vim * Up to
(excluding)
8.2.2434-3+deb11u1
运行在以下环境
系统 debian_12 vim * Up to
(excluding)
8.2.3565-1
运行在以下环境
系统 debian_9 vim * Up to
(excluding)
8.0.0197-4+deb9u3
运行在以下环境
系统 debian_sid vim * Up to
(excluding)
8.2.3565-1
运行在以下环境
系统 fedora_34 vim * Up to
(excluding)
8.2.3717-1.fc34
CVSS3评分
7.8
  • 攻击路径
    本地
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-122 堆缓冲区溢出
CWE-787 跨界内存写
阿里云安全产品覆盖情况