中危 systemd 安全漏洞

CVE编号

CVE-2021-3997

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-02-23
漏洞描述
systemd是德国Lennart Poettering个人开发者的一款基于Linux的系统和服务管理器。该产品兼容了SysV和LSB的启动脚本,且提供了一个用来表示系统服务间依赖关系的框架。

systemd存在安全漏洞,该漏洞是由于systemd-tmpfiles中不受控制的递归而存在的。本地用户可以在tmp文件夹中创建多个嵌套目录,case systemd会在系统启动时崩溃。该漏洞允许本地用户执行拒绝服务(DoS)攻击。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

http://github.com/systemd/systemd/commit/55a89ea1b4088a6d84ba0bd3cd8e648bd51f1ebf
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 debian_10 systemd * Up to
(including)
241-7~deb10u8
运行在以下环境
系统 debian_11 systemd * Up to
(excluding)
247.3-7
运行在以下环境
系统 debian_9 systemd * Up to
(including)
232-25+deb9u12
运行在以下环境
系统 fedora_34 systemd * Up to
(excluding)
248.10-1.fc34
运行在以下环境
系统 fedora_35 systemd * Up to
(excluding)
249.9-1.fc35
运行在以下环境
系统 opensuse_Leap_15.3 systemd * Up to
(excluding)
246.16-7.33.1
运行在以下环境
系统 opensuse_Leap_15.4 systemd * Up to
(excluding)
246.16-150300.7.39.1
运行在以下环境
系统 ubuntu_20.04 systemd * Up to
(excluding)
245.4-4ubuntu3.15
运行在以下环境
系统 ubuntu_21.04 systemd * Up to
(excluding)
247.3-3ubuntu3.7
运行在以下环境
系统 ubuntu_21.10 systemd * Up to
(excluding)
248.3-1ubuntu8.2
阿里云评分
5.7
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
阿里云安全产品覆盖情况