高危 HAProxy整数溢出漏洞(CVE-2021-40346)

CVE编号

CVE-2021-40346

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2021-09-09 01:15:00
漏洞描述
HAProxy 是一款提供高可用性、负载均衡以及基于TCP(第四层)和HTTP(第七层)应用的代理软件。
HAProxy 存在整数溢出漏洞,攻击者可以绕过对重复 HTTP Content-Length标头的检查,从而允许请求走私攻击或响应拆分攻击。

影响版本:
2.0.0<= haproxy <2.0.25
2.2.0<= haproxy <2.2.17
2.3.0<= haproxy <2.3.14
2.4.0<= haproxy <2.4.4

修复版本:
2.0.25
2.2.17
2.3.14
2.4.4

解决建议
建议将该软件升级至修复版本或最新版本。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haproxy haproxy * From
(including)
2.0.0
Up to
(excluding)
2.0.25
运行在以下环境
应用 haproxy haproxy * From
(including)
2.2.0
Up to
(excluding)
2.2.17
运行在以下环境
应用 haproxy haproxy * From
(including)
2.3.0
Up to
(excluding)
2.3.14
运行在以下环境
应用 haproxy haproxy * From
(including)
2.4.0
Up to
(excluding)
2.4.4
运行在以下环境
应用 haproxy haproxy 2.5 -
运行在以下环境
系统 debian debian_linux 11.0 -
运行在以下环境
系统 debian_11 haproxy * Up to
(excluding)
2.2.9-2+deb11u2
运行在以下环境
系统 debian_12 haproxy * Up to
(excluding)
2.2.16-2
运行在以下环境
系统 fedora_33 haproxy * Up to
(excluding)
2.2.17-1.fc33
运行在以下环境
系统 fedora_34 haproxy * Up to
(excluding)
2.3.14-1.fc34
运行在以下环境
系统 opensuse_Leap_15.2 haproxy * Up to
(excluding)
2.0.14-lp152.2.6.1
运行在以下环境
系统 opensuse_Leap_15.3 haproxy * Up to
(excluding)
2.0.14-11.11.1
运行在以下环境
系统 ubuntu_20.04 haproxy * Up to
(excluding)
2.0.13-2ubuntu0.3
运行在以下环境
系统 ubuntu_21.04 haproxy * Up to
(excluding)
2.2.9-1ubuntu0.2
阿里云评分
7.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况