高危 Apache HTTP Server mod_proxy 模块 SSRF漏洞

CVE编号

CVE-2021-40438

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-09-17 00:00:00
漏洞描述
Apache HTTP Server是美国阿帕奇(Apache)基金会的一款开源网页服务器。该服务器具有快速、可靠且可通过简单的API进行扩充的特点。
Apache HTTP Server mod_proxy 模块存在SSRF漏洞,远程攻击者可通过发送精心构造的 uri-path 导致 mod_proxy 将请求转发到攻击者所选择的源服务器。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://access.redhat.com/security/cve/cve-2021-40438
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * Up to
(including)
2.4.48
运行在以下环境
系统 alibaba_cloud_linux_2.1903 httpd * Up to
(excluding)
2.4.6-97.1.al7.1
运行在以下环境
系统 alpine_3.11 apache2 * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.12 apache2 * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.13 apache2 * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.14 apache2 * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_3.15 httpd * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 alpine_edge apache2 * Up to
(excluding)
2.4.49-r0
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.51-1.amzn2
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.51-1.94.amzn1
运行在以下环境
系统 centos_7 httpd * Up to
(excluding)
2.4.6-97.el7.centos.1
运行在以下环境
系统 debian_10 apache2 * Up to
(excluding)
2.4.38-3+deb10u6
运行在以下环境
系统 debian_11 apache2 * Up to
(excluding)
2.4.51-1~deb11u1
运行在以下环境
系统 debian_12 apache2 * Up to
(excluding)
2.4.48-4
运行在以下环境
系统 debian_9 apache2 * Up to
(excluding)
2.4.25-3+deb9u11
运行在以下环境
系统 fedoraproject fedora 34 -
运行在以下环境
系统 fedoraproject fedora 35 -
运行在以下环境
系统 fedora_34 apache2 * Up to
(excluding)
2.4.49-1.fc34
运行在以下环境
系统 fedora_35 apache2 * Up to
(excluding)
2.4.49-1.fc35
运行在以下环境
系统 opensuse_Leap_15.2 httpd * Up to
(excluding)
2.4.43-lp152.2.21.1
运行在以下环境
系统 opensuse_Leap_15.3 httpd * Up to
(excluding)
2.4.43-3.32.1
运行在以下环境
系统 suse_12_SP5 apache2 * Up to
(excluding)
2.4.23-29.80.1
运行在以下环境
系统 suse_12_SP5 httpd * Up to
(excluding)
2.4.23-29.80.1
阿里云评分
7.2
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-918 服务端请求伪造(SSRF)
阿里云安全产品覆盖情况