高危 Apache Tomcat 安全漏洞

CVE编号

CVE-2021-41079

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-09-15 00:00:00
漏洞描述
Apache Tomcat是美国阿帕奇(Apache)基金会的一款轻量级Web应用服务器。该程序实现了对Servlet和JavaServer Page(JSP)的支持。
Apache Tomcat 存在安全漏洞,该漏洞源于程序处理某些 TLS 数据包时存在无限循环,远程攻击者可以向应用程序发送特制的数据包,消耗所有可用的系统资源并导致拒绝服务条件。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://tomcat.apache.org/security-10.html。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache tomcat * From
(including)
10.0.0
Up to
(including)
10.0.2
运行在以下环境
应用 apache tomcat * From
(including)
8.5.0
Up to
(excluding)
8.5.64
运行在以下环境
应用 apache tomcat * From
(including)
9.0.0
Up to
(excluding)
9.0.44
运行在以下环境
系统 amazon_AMI tomcat9 * Up to
(excluding)
3.0-api-8.5.69-1.88.amzn1
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_10 tomcat9 * Up to
(excluding)
9.0.31-1~deb10u6
运行在以下环境
系统 debian_11 tomcat9 * Up to
(excluding)
9.0.43-2~deb11u2
运行在以下环境
系统 debian_12 tomcat9 * Up to
(excluding)
9.0.43-3
运行在以下环境
系统 debian_9 tomcat9 * Up to
(excluding)
8.5.54-0+deb9u8
运行在以下环境
系统 debian_sid tomcat9 * Up to
(excluding)
9.0.43-3
运行在以下环境
系统 opensuse_Leap_15.2 tomcat9 * Up to
(excluding)
9.0.36-lp152.2.25.1
运行在以下环境
系统 opensuse_Leap_15.3 tomcat9 * Up to
(excluding)
9.0.36-13.1
运行在以下环境
系统 suse_12_SP5 tomcat9 * Up to
(excluding)
9.0.36-3.71.1
阿里云评分
7.0
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况