中危 Docker CLI 信息泄露漏洞

CVE编号

CVE-2021-41092

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-10-05
漏洞描述
Docker是美国Docker公司的一款开源的应用容器引擎。该产品支持在Linux系统上创建一个容器(轻量级虚拟机)并部署和运行应用程序,以及通过配置文件实现应用程序的自动化安装、部署和升级。

Docker CLI 存在信息泄露漏洞,该漏洞源于在 Docker CLI 中发现了一个错误,其中运行 docker login my-private-registry.example.com并带有一个错误配置的配置文件(通常是 ~/.docker/config.json),其中列出了 credsStore 或 credHelpers 无法执行将导致任何提供的凭据被发送到registry-1.docker.io而不是预期的私有注册表。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/docker/cli/security/advisories/GHSA-99pg-grm5-qq3v
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 docker command_line_interface * Up to
(excluding)
20.10.9
运行在以下环境
系统 alpine_3.14 docker * Up to
(excluding)
20.10.9-r0
运行在以下环境
系统 alpine_3.15 docker * Up to
(excluding)
20.10.9-r0
运行在以下环境
系统 alpine_3.16 docker * Up to
(excluding)
20.10.9-r0
运行在以下环境
系统 alpine_edge docker * Up to
(excluding)
20.10.9-r0
运行在以下环境
系统 amazon_2 docker * Up to
(excluding)
20.10.7-3.amzn2
运行在以下环境
系统 amazon_AMI docker * Up to
(excluding)
20.10.7-3.71.amzn1
运行在以下环境
系统 debian_10 docker * Up to
(including)
18.09.1+dfsg1-7.1+deb10u3
运行在以下环境
系统 debian_11 docker * Up to
(excluding)
20.10.5+dfsg1-1+deb11u1
运行在以下环境
系统 debian_12 docker * Up to
(including)
20.10.8+dfsg1-2
运行在以下环境
系统 debian_sid docker * Up to
(including)
20.10.10+dfsg1-1
运行在以下环境
系统 fedora_34 docker * Up to
(excluding)
1.5.7-1.fc34
运行在以下环境
系统 fedora_35 docker * Up to
(excluding)
1.5.7-1.fc35
运行在以下环境
系统 opensuse_Leap_15.2 docker * Up to
(excluding)
20.10.9_ce-lp152.2.18.1
运行在以下环境
系统 opensuse_Leap_15.3 docker * Up to
(excluding)
20.10.9_ce-156.1
运行在以下环境
系统 ubuntu_18.04 docker * Up to
(excluding)
20.10.7-0ubuntu5~18.04.3
运行在以下环境
系统 ubuntu_18.04.5_lts docker.io * Up to
(excluding)
20.10.7-0ubuntu5~18.04.3
运行在以下环境
系统 ubuntu_20.04 docker * Up to
(excluding)
20.10.7-0ubuntu5~20.04.2
运行在以下环境
系统 ubuntu_21.04 docker * Up to
(excluding)
20.10.7-0ubuntu5~21.04.2
运行在以下环境
系统 ubuntu_21.10 docker * Up to
(excluding)
20.10.7-0ubuntu5.1
运行在以下环境
系统 ubuntu_22.04 docker * Up to
(excluding)
20.10.7-0ubuntu7
阿里云评分
5.1
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-200 信息暴露
CWE-522 不充分的凭证保护机制
阿里云安全产品覆盖情况