低危 vim 安全漏洞

CVE编号

CVE-2021-4136

利用情况

暂无

补丁情况

N/A

披露时间

2021-12-20
漏洞描述
Vim是一款基于UNIX平台的编辑器。

vim存在安全漏洞,目前尚无此漏洞的更多信息,请随时关注阿里云漏洞库或厂商公告。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/vim/vim/commit/605ec91e5a7330d61be313637e495fa02a6dc264
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(excluding)
8.2.3847
运行在以下环境
系统 alpine_3.12 vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 alpine_3.13 vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 alpine_3.14 vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 alpine_3.15 vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 alpine_3.16 vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 alpine_edge vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 amazon_2 vim * Up to
(excluding)
8.2.4006-1.amzn2.0.1
运行在以下环境
系统 amazon_AMI vim * Up to
(excluding)
8.2.4006-1.1.amzn1
运行在以下环境
系统 debian_10 vim * Up to
(including)
8.1.0875-5
运行在以下环境
系统 debian_11 vim * Up to
(including)
8.2.2434-3+deb11u1
运行在以下环境
系统 debian_12 vim * Up to
(including)
8.2.3565-1
运行在以下环境
系统 debian_9 vim * Up to
(including)
8.0.0197-4+deb9u3
运行在以下环境
系统 debian_sid vim * Up to
(including)
8.2.3565-1
运行在以下环境
系统 fedora_34 vim * Up to
(excluding)
8.2.4006-1.fc34
运行在以下环境
系统 fedora_35 vim * Up to
(excluding)
8.2.4006-1.fc35
阿里云评分
2.8
  • 攻击路径
    N/A
  • 攻击复杂度
    N/A
  • 权限要求
    N/A
  • 影响范围
    N/A
  • EXP成熟度
    N/A
  • 补丁情况
    N/A
  • 数据保密性
    N/A
  • 数据完整性
    N/A
  • 服务器危害
    N/A
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-122 堆缓冲区溢出
CWE-787 跨界内存写
阿里云安全产品覆盖情况