中危 Ruby 输入验证错误漏洞

CVE编号

CVE-2021-41817

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-12-06
漏洞描述
Ruby是松本行弘个人开发者的一种跨平台、面向对象的动态类型编程语言。
Ruby Date Gem 中存在输入验证错误漏洞,该漏洞源于产品的日期解析方法实现存在错误。攻击者可通过该漏洞导致拒绝服务。
以下产品及版本受到影响:
Ruby Date Gem 2.0.0 版本及之前版本、
Ruby Date Gem 3.0.1 版本及之前版本、
Ruby Date Gem 3.1.1 版本及之前版本、
Ruby Date Gem 3.2.0 版本及之前版本。
解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://www.ruby-lang.org/en/news/2021/11/15/date-parsing-method-regexp-dos-cve-2021-41817/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 opensuse factory - -
运行在以下环境
应用 redhat software_collections - -
运行在以下环境
应用 ruby-lang date * Up to
(excluding)
2.0.1
运行在以下环境
应用 ruby-lang date * From
(including)
3.0.0
Up to
(excluding)
3.0.2
运行在以下环境
应用 ruby-lang date * From
(including)
3.1.0
Up to
(excluding)
3.1.2
运行在以下环境
应用 ruby-lang date 3.2.0 -
运行在以下环境
应用 ruby-lang ruby * From
(including)
2.6.0
Up to
(excluding)
2.6.9
运行在以下环境
应用 ruby-lang ruby * From
(including)
2.7.0
Up to
(excluding)
2.7.5
运行在以下环境
应用 ruby-lang ruby * From
(including)
3.0.0
Up to
(excluding)
3.0.3
运行在以下环境
系统 alpine_3.12 ruby * Up to
(excluding)
2.7.5-r0
运行在以下环境
系统 alpine_3.13 ruby * Up to
(excluding)
2.7.5-r0
运行在以下环境
系统 alpine_3.14 ruby * Up to
(excluding)
2.7.5-r0
运行在以下环境
系统 alpine_3.15 ruby * Up to
(excluding)
3.0.3-r0
运行在以下环境
系统 alpine_edge ruby * Up to
(excluding)
3.0.3-r0
运行在以下环境
系统 debian_10 ruby * Up to
(excluding)
2.5.5-3+deb10u3
运行在以下环境
系统 debian_11 ruby * Up to
(excluding)
2.7.4-1
运行在以下环境
系统 debian_12 ruby * Up to
(excluding)
2.7.4-1
运行在以下环境
系统 debian_9 ruby * Up to
(excluding)
2.3.3-1+deb9u11
运行在以下环境
系统 debian_sid ruby * Up to
(excluding)
3.0.2-5
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况