中危 Wireshark 注入漏洞(CVE-2021-4186)

CVE编号

CVE-2021-4186

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-12-31
漏洞描述
Wireshark(前称Ethereal)是Wireshark团队的一套网络数据包分析软件。该软件的功能是截取网络数据包,并显示出详细的数据以供分析。

Wireshark 3.4.0 - 3.4.10版本存在注入漏洞,该漏洞源于Gryphon解析器崩溃。攻击者可利用该漏洞通过数据包注入或特制的捕获文件造成拒绝服务。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.wireshark.org/security/wnpa-sec-2021-16.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 wireshark wireshark * From
(including)
3.4.0
Up to
(including)
3.4.10
运行在以下环境
系统 alpine_3.15 kernel * Up to
(excluding)
3.4.13-r0
运行在以下环境
系统 alpine_3.16 kernel * Up to
(excluding)
3.4.11-r0
运行在以下环境
系统 alpine_edge kernel * Up to
(excluding)
3.4.11-r0
运行在以下环境
系统 amazon_2 kernel * Up to
(excluding)
5.10.75-79.358.amzn2
运行在以下环境
系统 centos_8 kernel * Up to
(excluding)
4.18.0-372.9.1.el8
运行在以下环境
系统 debian_10 kernel * Up to
(including)
2.6.20-0+deb10u3
运行在以下环境
系统 debian_11 kernel * Up to
(including)
3.4.10-0+deb11u1
运行在以下环境
系统 debian_9 kernel * Up to
(including)
2.6.7-1~deb9u1
运行在以下环境
系统 fedora_33 kernel * Up to
(excluding)
5.14.10-100.fc33
运行在以下环境
系统 fedora_34 kernel * Up to
(excluding)
3.6.1-1.fc34
运行在以下环境
系统 fedora_35 kernel * Up to
(excluding)
3.6.1-1.fc35
运行在以下环境
系统 opensuse_Leap_15.2 kernel * Up to
(excluding)
5.3.18-lp152.102.1.lp152.8.49.1
运行在以下环境
系统 opensuse_Leap_15.3 kernel * Up to
(excluding)
4.12.14-197.102.2
运行在以下环境
系统 redhat_8 kernel * Up to
(excluding)
4.18.0-372.9.1.el8
运行在以下环境
系统 suse_12_SP5 kernel * Up to
(excluding)
4.12.14-122.98.1
运行在以下环境
系统 ubuntu_18.04 kernel * Up to
(excluding)
2.6.10-1~ubuntu18.04.0
阿里云评分
6.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-74 输出中的特殊元素转义处理不恰当(注入)
阿里云安全产品覆盖情况