中危 Pjsua Api 缓冲区错误漏洞(CVE-2021-43302)

CVE编号

CVE-2021-43302

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-02-17
漏洞描述
Pjsua Api是一个高级 Api。用于构建 Sip 多媒体用户代理应用程序。

Pjsua Api 存在缓冲区错误漏洞,攻击者可利用该漏洞通过控制的filename参数导致越界读取信息。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/pjsip/pjproject/security/advisories/GHSA-qcvw-h34v-c7r9
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 teluu pjsip * Up to
(including)
2.11.1
运行在以下环境
系统 alpine_3.16 asterisk * Up to
(excluding)
2.12-r0
运行在以下环境
系统 alpine_3.17 ring * Up to
(excluding)
2.12-r0
运行在以下环境
系统 alpine_edge asterisk * Up to
(excluding)
2.12-r0
运行在以下环境
系统 debian_10 asterisk * Up to
(excluding)
1:16.28.0~dfsg-0+deb10u1
运行在以下环境
系统 debian_11 asterisk * Up to
(excluding)
1:16.28.0~dfsg-0+deb11u1
运行在以下环境
系统 debian_12 asterisk * Up to
(including)
18.12.0~dfsg+~cs6.12.40431413-1
运行在以下环境
系统 debian_9 asterisk * Up to
(excluding)
2.5.5~dfsg-6+deb9u3
运行在以下环境
系统 debian_sid asterisk * Up to
(including)
20210112.2.b757bac~ds1-1
阿里云评分
5.6
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况