中危 NSS 安全漏洞

CVE编号

CVE-2021-43527

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-12-02
漏洞描述
NSS是美国Mozilla基金会的一个底层密码学库。该库支持多种加密算法,并且 Firefox 浏览器的TLS实现基于该库。

NSS verifies certificates 存在安全漏洞,该漏洞源于在NSS验证证书的方式中发现远程代码执行缺陷。攻击者可利用该漏洞在使用NSS编译的客户端应用程序中尝试发起SSL TLS连接时触发此问题从而威胁保密性、完整性以及系统可用性。


解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://packetstormsecurity.com/files/165110/NSS-Signature-Validation-Memory-Corruption.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 alibaba_cloud_linux_2.1903 nss * Up to
(excluding)
3.67.0-4.1.al7
运行在以下环境
系统 alpine_3.12 nss * Up to
(excluding)
3.60-r2
运行在以下环境
系统 alpine_3.13 nss * Up to
(excluding)
3.66-r0
运行在以下环境
系统 alpine_3.14 nss * Up to
(excluding)
3.66-r0
运行在以下环境
系统 alpine_3.15 nss * Up to
(excluding)
3.72-r1
运行在以下环境
系统 alpine_edge nss * Up to
(excluding)
3.73-r0
运行在以下环境
系统 amazon_2 nss * Up to
(excluding)
3.67.0-3.amzn2
运行在以下环境
系统 amazon_AMI nss * Up to
(excluding)
3.53.1-7.87.amzn1
运行在以下环境
系统 centos_8 nss * Up to
(excluding)
3.67.0-7.el8_5
运行在以下环境
系统 debian_10 nss * Up to
(excluding)
2:3.42.1-1+deb10u4
运行在以下环境
系统 debian_11 nss * Up to
(excluding)
2:3.61-1+deb11u1
运行在以下环境
系统 debian_12 nss * Up to
(excluding)
3.72-2
运行在以下环境
系统 debian_9 nss * Up to
(excluding)
2:3.26.2-1.1+deb9u3
运行在以下环境
系统 fedora_34 nss * Up to
(excluding)
3.73.0-1.fc34
运行在以下环境
系统 fedora_35 nss * Up to
(excluding)
3.73.0-1.fc35
运行在以下环境
系统 opensuse_Leap_15.3 nss * Up to
(excluding)
3.68.1-3.61.1
运行在以下环境
系统 redhat_8 nss * Up to
(excluding)
3.67.0-7.el8_5
运行在以下环境
系统 suse_12_SP5 nss * Up to
(excluding)
3.68.1-58.57.1
阿里云评分
4.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况