高危 Laravel Framework 代码问题漏洞

CVE编号

CVE-2021-43617

利用情况

EXP 已公开

补丁情况

没有补丁

披露时间

2021-11-15
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
Laravel Framework是Taylor Otwell个人开发者的一款基于PHP的Web应用程序开发框架。Illuminate是其中的一个组件。
Laravel Framework8.70.2之前版本存在安全漏洞,该漏洞源于框架并没有充分阻止可执行PHP内容的上传,因为Illuminate/Validation/Concerns/ValidatesAttributes.php缺少对.phar文件的检查,这些文件在基于Debian的系统上被处理为application/x-httpd-php。在某些用例中,这可能与图像上传的文件类型验证有关。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://github.com/laravel/framework
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 laravel framework * Up to
(including)
8.70.2
运行在以下环境
系统 debian_11 php-laravel-framework * Up to
(excluding)
6.20.14+dfsg-2+deb11u1
运行在以下环境
系统 debian_12 php-laravel-framework * Up to
(including)
6.20.14+dfsg-2
运行在以下环境
系统 debian_sid php-laravel-framework * Up to
(including)
6.20.14+dfsg-2
阿里云评分
7.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    没有补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-434 危险类型文件的不加限制上传
阿里云安全产品覆盖情况