中危 runc 输入验证错误漏洞

CVE编号

CVE-2021-43784

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-12-07
漏洞描述
runc是一款用于根据OCI规范生成和运行容器的CLI(命令行界面)工具。
runc 存在输入验证错误漏洞,该漏洞源于integer overflow in netlink bytemsg length字段允许攻击者可利用该漏洞覆盖基于netlink的容器配置。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/opencontainers/runc/security/advisories/GHSA-v95c-p5hm-xq8f
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 linuxfoundation runc * Up to
(excluding)
1.0.3
运行在以下环境
系统 alpine_edge runc * Up to
(excluding)
1.0.3-r0
运行在以下环境
系统 debian_10 runc * Up to
(excluding)
1.0.0~rc6+dfsg1-3
运行在以下环境
系统 debian_11 runc * Up to
(excluding)
1.0.0~rc93+ds1-5
运行在以下环境
系统 debian_12 runc * Up to
(excluding)
1.0.2+ds1-2
运行在以下环境
系统 debian_9 runc * Up to
(excluding)
0.1.1+dfsg1-2+deb9u3
运行在以下环境
系统 opensuse_Leap_15.2 runc * Up to
(excluding)
1.0.3-lp152.2.12.1
运行在以下环境
系统 opensuse_Leap_15.3 runc * Up to
(excluding)
1.0.3-27.1
阿里云评分
6.2
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况