中危 gnu mailman 跨站请求伪造漏洞

CVE编号

CVE-2021-44227

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-12-02
漏洞描述
GNU Mailman是GNU社区的一套免费的用于管理电子邮件讨论和电子邮件列表的软件。该软件可与Web项目集成,使用户方便管理邮件订阅帐号,并提供内置归档、自动转发处理、内容过滤和反垃圾过滤器等功能。
GNU Mailman 2.1.38之前版本存在安全漏洞,该漏洞源于列表成员或版主可以获得CSRF令牌并创建一个管理请求(使用该令牌)来设置新的管理密码或进行其他更改。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://bugs.launchpad.net/mailman/+bug/1952384
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu mailman * Up to
(including)
2.1.37
运行在以下环境
系统 alibaba_cloud_linux_2.1903 mailman * Up to
(excluding)
2.1.15-30.1.al7.2
运行在以下环境
系统 debian_10 mailman * Up to
(excluding)
2.1.29-1+deb10u1
运行在以下环境
系统 debian_9 mailman * Up to
(excluding)
2.1.23-1+deb9u5
阿里云评分
5.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-352 跨站请求伪造(CSRF)
阿里云安全产品覆盖情况