低危 nodejs 信任管理问题漏洞

CVE编号

CVE-2021-44531

利用情况

暂无

补丁情况

N/A

披露时间

2022-02-25
漏洞描述
nodejs是是一个基于ChromeV8引擎的JavaScript运行环境通过对Chromev8引擎进行了封装以及使用事件驱动和非阻塞IO的应用让Javascript开发高性能的后台应用成为了可能。

nodejs 中存在信任管理问题漏洞,目前尚无此漏洞的相关信息。
解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:

https://nodejs.org/en/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 nodejs node.js * Up to
(excluding)
12.22.9
运行在以下环境
应用 nodejs node.js * From
(including)
14.0.0
Up to
(excluding)
14.18.3
运行在以下环境
应用 nodejs node.js * From
(including)
16.0.0
Up to
(excluding)
16.13.2
运行在以下环境
应用 nodejs node.js * From
(including)
17.0.0
Up to
(excluding)
17.3.1
运行在以下环境
系统 alpine_3.12 nodejs * Up to
(excluding)
12.22.10-r0
运行在以下环境
系统 alpine_3.13 nodejs * Up to
(excluding)
14.19.0-r0
运行在以下环境
系统 alpine_3.14 nodejs * Up to
(excluding)
14.19.0-r0
运行在以下环境
系统 alpine_3.15 nodejs * Up to
(excluding)
17.3.1-r0
运行在以下环境
系统 alpine_3.16 nodejs * Up to
(excluding)
11.0.15_p10-r0
运行在以下环境
系统 alpine_edge nodejs * Up to
(excluding)
17.3.1-r0
运行在以下环境
系统 debian_10 nodejs * Up to
(including)
10.24.0~dfsg-1~deb10u1
运行在以下环境
系统 debian_11 nodejs * Up to
(excluding)
12.22.12~dfsg-1~deb11u1
运行在以下环境
系统 debian_12 nodejs * Up to
(including)
12.22.10~dfsg-2
运行在以下环境
系统 debian_9 nodejs * Up to
(including)
4.8.2~dfsg-1
运行在以下环境
系统 debian_sid nodejs * Up to
(including)
12.22.10~dfsg-2
运行在以下环境
系统 fedora_34 nodejs * Up to
(excluding)
14.18.3-1.fc34
运行在以下环境
系统 fedora_34_Modular nodejs * Up to
(excluding)
16-3420220111194631.058368ca
运行在以下环境
系统 fedora_35 nodejs * Up to
(excluding)
16.13.2-1.fc35
运行在以下环境
系统 fedora_35_Modular nodejs * Up to
(excluding)
16-3520220111194631.f27b74a8
运行在以下环境
系统 opensuse_Leap_15.3 nodejs * Up to
(excluding)
12.22.9-4.25.1
阿里云评分
2.8
  • 攻击路径
    N/A
  • 攻击复杂度
    N/A
  • 权限要求
    N/A
  • 影响范围
    N/A
  • EXP成熟度
    N/A
  • 补丁情况
    N/A
  • 数据保密性
    N/A
  • 数据完整性
    N/A
  • 服务器危害
    N/A
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况