中危 calibre 安全漏洞

CVE编号

CVE-2021-44686

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-12-07
漏洞描述
Calibre是印度科维德·戈亚尔(Kovid Goyal)个人开发者的一个开源免费的全能电子书阅读管理与格式转换工具。

calibre 5.32.0 之前存在安全漏洞,该漏洞源于在 ebooks/conversion/preprocess.py 的 html_preprocess_rules 中包含容易受到 ReDoS(正则表达式拒绝服务)攻击的正则表达式。
解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:

https://github.com/kovidgoyal/calibre/compare/v5.31.1...v5.32.0
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 calibre-ebook calibre * Up to
(excluding)
5.32.0
运行在以下环境
系统 debian_10 calibre * Up to
(including)
3.39.1+dfsg-3
运行在以下环境
系统 debian_11 calibre * Up to
(including)
5.12.0+dfsg-1+deb11u1
运行在以下环境
系统 debian_12 calibre * Up to
(including)
5.32.0+dfsg-2
运行在以下环境
系统 debian_9 calibre * Up to
(including)
2.75.1+dfsg-1
运行在以下环境
系统 fedora_34 calibre * Up to
(excluding)
4.23.0-8.fc34
阿里云评分
6.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-400 未加控制的资源消耗(资源穷尽)
CWE-770 不加限制或调节的资源分配
阿里云安全产品覆盖情况