中危 Apache HTTP Server 缓冲区错误漏洞

CVE编号

CVE-2021-44790

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-12-20
漏洞描述
Apache HTTP Server是美国阿帕奇(Apache)基金会的一款开源网页服务器。该服务器具有快速、可靠且可通过简单的API进行扩充的特点。
Apache HTTP Server 中存在缓冲区错误漏洞,该漏洞源于产品的r:parsebody未能正确判断用户边界。攻击者可通过该漏洞导致缓冲区溢出。

以下产品及版本受到影响:Apache HTTP Server 2.4.51 版本及之前版本。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://httpd.apache.org/download.cgi#apache24
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * Up to
(including)
2.4.51
运行在以下环境
系统 alibaba_cloud_linux_2.1903 httpd * Up to
(excluding)
2.4.6-97.1.al7.4
运行在以下环境
系统 alpine_3.12 apache2 * Up to
(excluding)
2.4.52-r0
运行在以下环境
系统 alpine_3.13 apache2 * Up to
(excluding)
2.4.52-r0
运行在以下环境
系统 alpine_3.14 apache2 * Up to
(excluding)
2.4.52-r0
运行在以下环境
系统 alpine_3.15 apache2 * Up to
(excluding)
2.4.52-r0
运行在以下环境
系统 alpine_3.16 httpd * Up to
(excluding)
2.4.52-r0
运行在以下环境
系统 alpine_edge apache2 * Up to
(excluding)
2.4.52-r0
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.52-1.amzn2
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.52-1.95.amzn1
运行在以下环境
系统 centos_7 httpd * Up to
(excluding)
2.4.6-97.el7.centos.4
运行在以下环境
系统 debian_10 apache2 * Up to
(excluding)
2.4.38-3+deb10u7
运行在以下环境
系统 debian_11 apache2 * Up to
(excluding)
2.4.52-1~deb11u2
运行在以下环境
系统 debian_12 apache2 * Up to
(including)
2.4.51-2
运行在以下环境
系统 debian_9 apache2 * Up to
(excluding)
2.4.25-3+deb9u12
运行在以下环境
系统 debian_sid apache2 * Up to
(including)
2.4.51-2
运行在以下环境
系统 fedora_34 httpd * Up to
(excluding)
2.4.53-1.fc34
运行在以下环境
系统 fedora_35 apache2 * Up to
(excluding)
2.4.52-1.fc35
运行在以下环境
系统 fedora_36 httpd * Up to
(excluding)
2.4.53-1.fc36
运行在以下环境
系统 opensuse_Leap_15.3 httpd * Up to
(excluding)
2.4.51-3.37.1
运行在以下环境
系统 oracle_7 httpd * Up to
(excluding)
2.4.6-97.0.5.el7_9.4
运行在以下环境
系统 oracle_8 httpd * Up to
(excluding)
2.4.37-43.0.1.module+el8.5.0+20475+4f6a8fd5.1
运行在以下环境
系统 redhat_7 httpd * Up to
(excluding)
0:2.4.6-97.el7_9.4
运行在以下环境
系统 suse_12_SP5 httpd * Up to
(excluding)
2.4.51-35.7.1
运行在以下环境
系统 ubuntu_14.04 httpd * Up to
(excluding)
2.4.7-1ubuntu4.22+esm3
运行在以下环境
系统 ubuntu_16.04 httpd * Up to
(excluding)
2.4.18-2ubuntu3.17+esm4
运行在以下环境
系统 ubuntu_18.04 httpd * Up to
(excluding)
2.4.29-1ubuntu4.21
运行在以下环境
系统 ubuntu_20.04 httpd * Up to
(excluding)
2.4.41-4ubuntu3.9
运行在以下环境
系统 ubuntu_21.04 httpd * Up to
(excluding)
2.4.46-4ubuntu1.5
运行在以下环境
系统 ubuntu_21.10 httpd * Up to
(excluding)
2.4.48-3.1ubuntu3.2
运行在以下环境
系统 ubuntu_22.04 httpd * Up to
(excluding)
2.4.52-1ubuntu1
阿里云评分
6.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况