中危 Apache Log4j2 < 2.17.0 (>=Java 8 环境) 拒绝服务漏洞(CVE-2021-45105)

CVE编号

CVE-2021-45105

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2021-12-18
漏洞描述
CVE-2021-45105的Apache Log4j2拒绝服务攻击漏洞,当系统日志配置使用非默认的模式布局和上下文查找时,攻击者可以通过构造包含递归查找数据包的方式,控制线程上下文映射 (MDC),导致StackOverflowError产生并终止进程,实现拒绝服务攻击。该漏洞已于Log4j2版本2.17.0、2.12.3、2.3.1修复。仅使用log4j-api JAR文件而不使用log4j-core JAR文件的应用程序不受此漏洞的影响。
解决建议
1、>=Java 8 环境升级至2.17.0及以上版本;
2、Java 7 升级至2.12.3,Java 6 升级至2.3.1.
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 Apache Log4j2 * From
(including)
2.0-beta9
Up to
(excluding)
2.17.0
运行在以下环境
系统 amazon_2 apache-log4j2 * Up to
(excluding)
2.0.5-1.amzn2
运行在以下环境
系统 debian_10 apache-log4j2 * Up to
(excluding)
2.17.0-1~deb10u1
运行在以下环境
系统 debian_11 apache-log4j2 * Up to
(excluding)
2.17.0-1~deb11u1
运行在以下环境
系统 debian_12 apache-log4j2 * Up to
(including)
2.16.0-1
运行在以下环境
系统 debian_9 apache-log4j2 * Up to
(excluding)
2.12.3-0+deb9u1
运行在以下环境
系统 debian_sid apache-log4j2 * Up to
(including)
2.16.0-1
运行在以下环境
系统 fedora_34 apache-log4j2 * Up to
(excluding)
2.17.0-1.fc34
运行在以下环境
系统 fedora_35 apache-log4j2 * Up to
(excluding)
2.17.0-1.fc35
运行在以下环境
系统 opensuse_Leap_15.2 apache-log4j2 * Up to
(excluding)
2.17.0-lp152.3.12.1
运行在以下环境
系统 opensuse_Leap_15.3 apache-log4j2 * Up to
(excluding)
2.17.0-4.13.1
运行在以下环境
系统 ubuntu_18.04 apache-log4j2 * Up to
(excluding)
2.12.4-0ubuntu0.1
运行在以下环境
系统 ubuntu_20.04 apache-log4j2 * Up to
(excluding)
2.17.0-0.20.04.1
运行在以下环境
系统 ubuntu_21.04 apache-log4j2 * Up to
(excluding)
2.17.0-0.21.04.1
运行在以下环境
系统 ubuntu_21.10 apache-log4j2 * Up to
(excluding)
2.17.0-0.21.10.1
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
CWE-674 未经控制的递归
阿里云安全产品覆盖情况